windows 7 internet issues, dns server not responding and gateway can't be found after getting my hard drive replaced

hi i am having a problem with my gateway laptop. i just recently paid a technician to repair my laptop. he put in a brand new hard drive and reinstalled the windows 7 software and ever since he did that my internet does not work. it sayd the default gateway is not available and the dns server is not rsponding so i took it back to the technician and he said it has nothing to do what he did and that he installed everything so i called comcast and they came out to check. connection is perfect and they even gave me a new modem. i'm still having the same problem. comcast is saying it's not them and the computer must be missing some hardware and my technician is saying it's not!!! 

Hi Elenita,

Thank you for posting the query in Microsoft Community Forums!!

I apologize from the inconvenience and I understand that you are unable to connect to network and you receive an error message “DNS server not responding and gateway cannot be found.”

There may be a possibility that the router is not able to assign IP (Internet Protocol) address properly or if it has incorrect DNS settings.

Try these methods and check if it helps.

Method 1
Run the network troubleshooter to diagnose and repair any problem related to your network. Access the link mentioned below for steps:
Method 2
Disable the security software temporarily and check if it helps.
Note: Antivirus software can help protect your computer against viruses and other security threats. In most cases, you should not disable your antivirus software. If you do have to temporarily disable it to install other software, you should re-enable it as soon as you're done. If you are connected to the Internet or a network during the time your antivirus software is disabled, your computer is vulnerable to attacks.
Method 3
For a full list of steps to try, see the Wired and Wireless tutorial on this page.
Wired and wireless network connection problems in Windows
Method 4
Check to see whether setting a static IP address for the LAN adapter helps.
a) Click Start, type ncpa.cpl and press Enter.
b) Right click on the connection that you use for the local connection, and then click Properties.
c) Click to select Internet Protocol Version 4 (TCP/IPv4) and then clickProperties.
d) In the Internet Protocol window, change the Preferred DNS server to
e) In (TCP/IPv4) Properties, select the Validates settings upon exit check box.
f) Click OK twice to complete the modification.
Repeat the steps and set the Preferred DNS server to if the above fails.

If you need further assistance reply to this post and I’d be happy to work with you on other options.

2 people found this reply helpful

Was this reply helpful?


Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated May 5, 2021 Views 2,005 Applies to: