Windows 7 Internet Connection Sharing issue "(null)"

When I try to share my wireless internet connection or my cable connection in windows 7 it gives me this error message, after asking to change the other adapter's ip to 192.168.137.1:

---------------------------
Network Connections
---------------------------
An error occurred while Internet Connection Sharing was being enabled.



(null)
---------------------------
OK  
---------------------------

That is not very clear, so I went to the windows system's event logs and found this warning message all the times I tried to enable internet connection sharing:

The ICS_IPV6 was unable to allocate bytes of memory. This may indicate that the system is low on virtual memory, or that the memory manager has encountered an internal error.

 

Thinking that it would be a clue of some type, I tried enabling all IPv6 protocols in all my adapters, even the disabled ones (I use them all disabled by default), but the message and the system log registry kept showing, thus, no internet sharing.

Any help would be much appreciated.
Thanks

Ps: please dont ask me why i do need this... the reason would be another problem, and i dont want a workaround, i want to share my internet connection... is it that complex?

|
Answer
Answer
All the following services must be thus configured in order to use ICS:
 
Application Layer Gateway Service
Network Connections
Network Location Awareness (NLA)
Plug And Play
Remote Access Auto Connection Manager
Remote Access Connection Manager
Remote Procedure Call (RPC)
Telephony

I've got the same problem and I solved it enabling that services but also it's necessary to enable "Windows firewall" service.

35 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Answer
Answer
Hi MichelCosta,
 
May be not all the services that run Internet Connection Sharing(ICS) are enabled. I'd suggest you to strat from the begining and make sure the below dependency servies are enabled.
 
1. Click Start, Run, type services.msc, and click OK.
 
2. To enable a service, find it in the right pane and double-click its entry.
 
3.Be sure its Startup Type is set to Automatic and click OK.
 
All the following services must be thus configured in order to use ICS:
 
Application Layer Gateway Service
Network Connections
Network Location Awareness (NLA)
Plug And Play
Remote Access Auto Connection Manager
Remote Access Connection Manager
Remote Procedure Call (RPC)
Telephony
 
After verifying and/or configuring Automatic startup for each of these services, close the Services window and restart the computer before attempting again to enable ICS.
 
FYI:
 

If that does not work, turn off User Account Control (UAC) temporarily and then try again.

Note: User Account Control (UAC) can help prevent unauthorized changes to your computer. UAC notifies you when changes are going to be made to your computer that require administrator-level permission. These types of changes can affect the security of your computer or can affect settings for other people that use the computer. So turn it on after the test.
 

Azeez Nadeem - Microsoft Support

[If this post was helpful, please click the "Vote as Helpful" (green triangle) button. If it helps in resolving your issue, click "Propose As Answer" or "Mark as Answer" button. By proposing/marking a post as Answered, or Helpful you help others find the answer faster.]

24 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated January 23, 2021 Views 83,223 Applies to: