Windows 7 COM modem: no ATD in modem log

I am using a 3G mobile phone as a modem for dail-up connection. It appears to be a Microsoft USB Modem (COM10), and I add a 33600 standard modem associated with this COM port.

 

at+cgdcont=4,"ip","cmnet";+cgeqreq=4,2,1024,2048; is the initialization command.

 

After I add a Dial-up connection, and dial "*99***4#", a dialog showing "modems connection..." appears for tens of seconds, and then report Error 638: The remote server is not responding in a timely fashion.

 

Below is the modem's log. I suspect why I can't see ATD*99***4# after initialization command is done. Anything wrong?

 

BTW, the initialization command and "*99***4#" are both double checked, they are correct.

 

03-27-2012 14:50:23.135 - File: C:\Windows\system32\tapisrv.dll, Version 6.1.7601  
03-27-2012 14:50:23.135 - File: C:\Windows\system32\unimdm.tsp, Version 6.1.7601  
03-27-2012 14:50:23.135 - File: C:\Windows\system32\unimdmat.dll, Version 6.1.7601  
03-27-2012 14:50:23.135 - File: C:\Windows\system32\uniplat.dll, Version 6.1.7600  
03-27-2012 14:50:23.135 - File: C:\Windows\system32\drivers\modem.sys, Version 6.1.7600  
03-27-2012 14:50:23.135 - File: C:\Windows\system32\modemui.dll, Version 6.1.7600  
03-27-2012 14:50:23.135 - File: C:\Windows\system32\mdminst.dll, Version 6.1.7600  
03-27-2012 14:50:23.135 - Modem type: Standard 33600 bps Modem
03-27-2012 14:50:23.135 - Modem inf path: mdmgen.inf
03-27-2012 14:50:23.135 - Modem inf section: Gen336
03-27-2012 14:50:23.135 - Matching hardware ID: mdmgen336
03-27-2012 14:50:23.135 - Opening the modem device failed with error 00000005
03-27-2012 14:50:36.771 - File: C:\Windows\system32\tapisrv.dll, Version 6.1.7601  
03-27-2012 14:50:36.771 - File: C:\Windows\system32\unimdm.tsp, Version 6.1.7601  
03-27-2012 14:50:36.771 - File: C:\Windows\system32\unimdmat.dll, Version 6.1.7601  
03-27-2012 14:50:36.771 - File: C:\Windows\system32\uniplat.dll, Version 6.1.7600  
03-27-2012 14:50:36.771 - File: C:\Windows\system32\drivers\modem.sys, Version 6.1.7600  
03-27-2012 14:50:36.771 - File: C:\Windows\system32\modemui.dll, Version 6.1.7600  
03-27-2012 14:50:36.771 - File: C:\Windows\system32\mdminst.dll, Version 6.1.7600  
03-27-2012 14:50:36.771 - Modem type: Standard 33600 bps Modem
03-27-2012 14:50:36.771 - Modem inf path: mdmgen.inf
03-27-2012 14:50:36.771 - Modem inf section: Gen336
03-27-2012 14:50:36.771 - Matching hardware ID: mdmgen336
03-27-2012 14:50:36.771 - Opening Modem
03-27-2012 14:50:36.771 - 115200,8,N,1, ctsfl=1, rtsctl=2
03-27-2012 14:50:36.771 - Initializing modem.
03-27-2012 14:50:36.771 - DSR is low while initializing the modem. Verify modem is turned on.
03-27-2012 14:50:36.786 - Send: AT<cr>
03-27-2012 14:50:36.786 - Recv: <cr><lf>OK<cr><lf>
03-27-2012 14:50:36.786 - Interpreted response: OK
03-27-2012 14:50:36.802 - Send: ATE0V1<cr>
03-27-2012 14:50:36.802 - Recv: <cr><lf>OK<cr><lf>
03-27-2012 14:50:36.802 - Interpreted response: OK
03-27-2012 14:50:36.802 - TSP(0000): Making Call
03-27-2012 14:50:36.818 - Send: AT<cr>
03-27-2012 14:50:36.818 - Recv: <cr><lf>OK<cr><lf>
03-27-2012 14:50:36.818 - Interpreted response: OK
03-27-2012 14:50:36.818 - Sending user initialization commands.
03-27-2012 14:50:36.833 - Send: at+cgdcont=4,"ip","cmnet";+cgeqreq=4,2,1024,2048;<cr>
03-27-2012 14:50:36.849 - Recv: <cr><lf>OK<cr><lf>
03-27-2012 14:50:36.849 - Interpreted response: OK
03-27-2012 14:50:36.849 - Waiting for a call.
03-27-2012 14:50:36.864 - Send: ATS0=0<cr>
03-27-2012 14:50:36.864 - Recv: <cr><lf>OK<cr><lf>
03-27-2012 14:50:36.864 - Interpreted response: OK
03-27-2012 14:50:36.864 - 115200,8,N,1, ctsfl=1, rtsctl=2
03-27-2012 14:50:36.864 - Initializing modem.
03-27-2012 14:50:36.864 - DSR is low while initializing the modem. Verify modem is turned on.
03-27-2012 14:50:36.880 - Send: AT<cr>
03-27-2012 14:50:36.880 - Recv: <cr><lf>OK<cr><lf>
03-27-2012 14:50:36.880 - Interpreted response: OK
03-27-2012 14:50:36.896 - Send: ATE0V1<cr>
03-27-2012 14:50:36.896 - Recv: <cr><lf>OK<cr><lf>
03-27-2012 14:50:36.896 - Interpreted response: OK
03-27-2012 14:50:36.911 - Send: AT<cr>
03-27-2012 14:50:36.911 - Recv: <cr><lf>OK<cr><lf>
03-27-2012 14:50:36.911 - Interpreted response: OK
03-27-2012 14:50:36.911 - Sending user initialization commands.
03-27-2012 14:50:36.927 - Send: at+cgdcont=4,"ip","cmnet";+cgeqreq=4,2,1024,2048;<cr>
03-27-2012 14:50:36.942 - Recv: <cr><lf>OK<cr><lf>
03-27-2012 14:50:36.942 - Interpreted response: OK
03-27-2012 14:50:36.942 - TSP: Displaying Manual Dial Dialog03-27-2012 14:50:51.121 - Recv: <cr>
03-27-2012 14:50:51.121 - Interpreted response: Informative
03-27-2012 14:50:51.121 - Recv: <lf>
03-27-2012 14:50:51.121 - Interpreted response: Informative
03-27-2012 14:50:51.121 - Recv: +CSQ:22,0<cr><lf>
03-27-2012 14:50:51.121 - Unknown Response
03-27-2012 14:50:54.319 - Recv: <cr>
03-27-2012 14:50:54.319 - Interpreted response: Informative
03-27-2012 14:50:54.319 - Recv: <lf>
03-27-2012 14:50:54.319 - Interpreted response: Informative
03-27-2012 14:50:54.319 - Recv: +CSQ:21,0<cr><lf>
03-27-2012 14:50:54.319 - Unknown Response
03-27-2012 14:51:09.044 - Recv: <cr>
03-27-2012 14:51:09.044 - Interpreted response: Informative
03-27-2012 14:51:09.044 - Recv: <lf>
03-27-2012 14:51:09.044 - Interpreted response: Informative
03-27-2012 14:51:09.044 - Recv: +CSQ:22,0<cr><lf>
03-27-2012 14:51:09.044 - Unknown Response
03-27-2012 14:51:26.686 - TSP(0000): Closing Call
03-27-2012 14:51:26.686 - TSP Completing Async Operation(0x000102bd) Status 0x00000000
03-27-2012 14:51:26.686 - Waiting for a call.
03-27-2012 14:51:26.702 - Send: ATS0=0<cr>
03-27-2012 14:51:26.702 - Recv: <cr><lf>OK<cr><lf>
03-27-2012 14:51:26.702 - Interpreted response: OK
03-27-2012 14:51:26.702 - Session Statistics:
03-27-2012 14:51:26.702 -                Reads : 0 bytes
03-27-2012 14:51:26.702 -                Writes: 0 bytes
03-27-2012 14:51:26.733 - File: C:\Windows\system32\tapisrv.dll, Version 6.1.7601  
03-27-2012 14:51:26.733 - File: C:\Windows\system32\unimdm.tsp, Version 6.1.7601  
03-27-2012 14:51:26.733 - File: C:\Windows\system32\unimdmat.dll, Version 6.1.7601  
03-27-2012 14:51:26.733 - File: C:\Windows\system32\uniplat.dll, Version 6.1.7600  
03-27-2012 14:51:26.733 - File: C:\Windows\system32\drivers\modem.sys, Version 6.1.7600  
03-27-2012 14:51:26.733 - File: C:\Windows\system32\modemui.dll, Version 6.1.7600  
03-27-2012 14:51:26.733 - File: C:\Windows\system32\mdminst.dll, Version 6.1.7600  
03-27-2012 14:51:26.733 - Modem type: Standard 33600 bps Modem
03-27-2012 14:51:26.733 - Modem inf path: mdmgen.inf
03-27-2012 14:51:26.733 - Modem inf section: Gen336
03-27-2012 14:51:26.733 - Matching hardware ID: mdmgen336
03-27-2012 14:51:26.733 - Opening Modem
03-27-2012 14:51:26.733 - 115200,8,N,1, ctsfl=1, rtsctl=2
03-27-2012 14:51:26.733 - Initializing modem.
03-27-2012 14:51:26.733 - DSR is low while initializing the modem. Verify modem is turned on.
03-27-2012 14:51:26.749 - Send: AT<cr>
03-27-2012 14:51:26.749 - Recv: <cr><lf>OK<cr><lf>
03-27-2012 14:51:26.749 - Interpreted response: OK
03-27-2012 14:51:26.764 - Send: ATE0V1<cr>
03-27-2012 14:51:26.764 - Recv: <cr><lf>OK<cr><lf>
03-27-2012 14:51:26.764 - Interpreted response: OK
03-27-2012 14:51:26.780 - Send: AT<cr>
03-27-2012 14:51:26.780 - Recv: <cr><lf>OK<cr><lf>
03-27-2012 14:51:26.780 - Interpreted response: OK
03-27-2012 14:51:26.780 - Sending user initialization commands.
03-27-2012 14:51:26.795 - Send: at+cgdcont=4,"ip","cmnet";+cgeqreq=4,2,1024,2048;<cr>
03-27-2012 14:51:26.811 - Recv: <cr><lf>OK<cr><lf>
03-27-2012 14:51:26.811 - Interpreted response: OK
03-27-2012 14:51:26.811 - Session Statistics:
03-27-2012 14:51:26.811 -                Reads : 0 bytes
03-27-2012 14:51:26.811 -                Writes: 0 bytes

 
Question Info

Last updated March 13, 2018 Views 1,242 Applies to:
Hi,
 
1. What is the exact error message?
2. Have you made any changes in the computer before this issue occurred?
3. Have you installed mobile phone application to run as modem?
 
Error 638 may mean that the number being dialed is wrong or not filled in at all, or that somehow that the Operator-Assisted Dialing option has been checked for dial-up connections.
 
Method 1:
Install the mobile phone application in your computer and check.
 
Method 2:
Basic Troubleshooting - Always complete these steps prior to Advanced Troubleshooting
1. Pull the battery out of the phone while it is disconnected from the computer and charger
2. Restart the computer
3. Verify the Phone is capable of browsing the internet on the phone
Note: If the phone is unable to browse itself, contact your wireless provider.
4. Verify the connection and settings are correct by following the Connection Setup again to check the settings
5. Test the connection again
 
Method 3:
Advanced Troubleshooting
Verify the Dial-up number if filled in and correct:
1. On the computer go to
o Windows XP - Start > Control Panel > Network Connections
o Windows Vista - Start > Control Panel > Network and Sharing Center > Manage Network Connections
o Windows 7 - Start > Control Panel > Network and Sharing Center > Change Adapter Settings
2. Right click the Dial-up Connection then select Options
3. Verify the dial-up number is *99#
4. Test the connection if a change is made.
Verify the Dial-up number if filled in and correct:
1. On the computer go to
o Windows XP - Start > Control Panel > Network Connections
o Windows Vista - Start > Control Panel > Network and Sharing Center > Manage Network Connections
o Windows 7 - Start > Control Panel > Network and Sharing Center > Change Adapter Settings
2. At the top click the Advanced menu
3. Uncheck Operator-Assisted Dialing if it is checked (Click it to uncheck)
Note: If you do not see a menu or Advanced, press the Alt key on the keyboard.
4. Verify the dial-up number is *99#
5. Test the connection if a change is made

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This can not resolve my problem.

 

I think there is something wrong in the log: there is not "Dialing ...", but "Waiting for a call".

 

03-27-2012 14:51:26.686 - Waiting for a call.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.