Windows 7 can't resolve host names

Anyone know why Windows 7 should suddenly stop resolving host names? I've had the machine working fine for ages, but all of a sudden - without anything changing as far as I know - it now won't even ping a host (immediate response of "Ping request could not find host ...", even for host names in the hosts file). All web browsing ends in Server not Found (unless you type in the IP address). An XP machine connected to the same router works fine, and Linux running in a VM on the Windows 7 box also works fine. 

I have also tried the offending machine in a different network, alongside another Windows 7 box which is working fine, and it fails in exactly the same way. Incidentally, nslookup works fine (I see from other threads that it is possible for nslookup to resolve hostnames while ping can't, though not quite sure of the reason). Ping is fine on an IP address, needless to say.

Wireless or ethernet makes no difference. DNS/DHCP seem to be configured correctly.

I have spent a whole day now going through all the menus and ipconfig commands, but am baffled. Spybot comes up clean. Any ideas anyone?
 

Question Info


Last updated November 13, 2018 Views 27,273 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

 

You may try these steps.

 

  • Click Start
  • Click All Programs
  • Goto Accessories
  • Select Command Prompt
  • Right click on the Command prompt Run as Administrator
  • Type ipconfig /flushdns
  • Hit Enter.

 

Check if it helps.

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks Vidyaranjan.

Yes, I have tried ipconfig /flushdns, but it makes no difference. I have also tried:

ipconfig /release
ipconfig /renew
net stop dnscache
net start dnscache
netsh int ip reset resetlog.txt
netsh winsock reset catalog

... but none have made any difference.

Just to recap, nslookup works correctly, but ping and other programs which need to resolve host names - e.g. web browsers - fail.

Example:

C:\Windows\system32>nslookup www.google.co.uk

Server:  UnKnown

Address:  192.168.0.1

Non-authoritative answer:

Name:    www.google.co.uk

Addresses:  2a00:1450:400c:c06::5e

          173.194.78.94

C:\Windows\system32>ping www.google.co.uk

Ping request could not find host www.google.co.uk. Please check the name and try

 again.



The ping failure is immediate: there is no delay while it waits for a timeout or anything. What I find really strange is that ping seems to ignore the hosts file, completely. (I have checked, and the hosts file has not been tampered with!)

Any suggestions what else I could check?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

One thing I forgot to add, for what it's worth the Windows Network Troubleshooter comes up with:
"Windows could not automatically detect the network's proxy settings".

I have also tried to do a System Restore, which presumably would fix the problem - if only it worked. Unfortunate it fails with error "The specified object was not found (0x80042308)".

I would really appreciate some help with this - I am totally stumped. And the laptop is useless.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

What security software is installed on the computer?

 

Method 1:

 

Refer the steps below to check the proxy setting s for Internet Explorer.  

 

a)    Open Internet Explorer.

b)    Click Tools.

c)    Scroll down to Internet Options.

d)    Connections Tab.

e)    Lan Settings- Automatically detect settings.

f)     Click Ok.  

 

Method 2:  

 

Step 1:  

 

If you are using Windows Firewall, you may try resetting from the elevated command prompt:

 

a)    Click Start

b)    Type cmd in the start search box and hit Enter.

c)    When cmd is highlighted, right click on cmd and select “run as administrator

d)    Type the command and hit enter:

 

netsh advfirewall reset

 

 

Step 2:

 

Post the details of ipconfig /all command from the earlier post.

 

It would also be a good idea to run the same on the working computer and compare to make sure they are the same.

 

Hope the information is helpful.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same problems.  I have tried all the things listed above but still have problem with "resolving host" with all browsers.  This only happens on my Windows 7 system.  I have two other computers with XP on one and Windows 8.1 on the other.   I have NEVER had this issue on either of them.  Here is the output from my cmd screen with ipconfig/all.  I am at wits end trying to fix this problem.  I have my Sonicwall, firewall and each computer set to obtain DNS and IP address automatically.  I have tried forcing the DNS with Open DNS on the computer and I use Open DNS and Google on the firewall.  Please, Please, anyone with a fix to this problem would be greatly appreciated.

Thanks

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Harold>ipconfig/all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Photo2
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 00-26-18-5B-AD-75
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.168.62(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Tuesday, June 02, 2015 8:08:09 AM
   Lease Expires . . . . . . . . . . : Wednesday, June 03, 2015 8:08:09 AM
   Default Gateway . . . . . . . . . : 192.168.168.168
   DHCP Server . . . . . . . . . . . : 192.168.168.168
   DNS Servers . . . . . . . . . . . : 208.67.222.222
                                       208.67.220.220
                                       8.8.4.4
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{0A1CD997-8C3B-4F5E-BA3C-7D5513129C21}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

C:\Users\Harold>

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hairout - Please help! I am having the same identical issue and I cannot figure out how to fix it. My help desk for my company can't either. How did you resolve it???

Liz

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Sorry for the delay.

I see this thread is more than 10 days old. If you are  facing the same issue. Please let us know so that we can proceed with the next step.

Thank you.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am also having this issue. It started just a few days ago. All VMs resolve names fine. internet based names resolve fine. It is only local names, on various subnets, that do not. I have tried everything already mentioned in this thread and many of the more popular recommendations in some others. Nothing works. Thanksfully, my servers and resources have permanent IPs, managed by DHCP. It is the laptops and other PCs that have the IP change from time to time. Friends, family, etc. Please, any other suggestions would be very welcome.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same thing happening with my laptop.

It is not related to the Router in my WiFI home network because other devices are working fine.

Some times enabling/disabling the Wireless adapter solves the problem, but other times I need to restart the laptop.

Have this problem 3 or 4 times a day ...

Appreciate your help.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

HI, I have been having exactly the same problem in the last few days on Windows 7 32-bit.

The laptop worked fine up until July 22 2015. On that and the following day, two critical updates have been automatically installed at 3 am. 

Since then, it has been a constant struggle (up until one hour ago!) to make the network connection work - and it is still unstable. I have restored the machine to an earlier time, reset lots of time wlan connections, added ports to the Firewall to try go through the IPs. I have got another automatically downloaded update pending and I am shivering, no joke.

Meanwhile I have found the first solution here which works for me  http://www.sevenforums.com/browsers-mail/322704-resolving-host-issue-google.html

, but my network stops or freezes not only for Chrome, but also for Firefox and Internet Explorer. 

I can confirm that with this issue the machine is useless and the dose of daily frustration really high.

Many thanks for your help in advance.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.