Windows 7 and Mac 10.5 network file sharing

I am having extreme difficulties sharing files over my home network! I have 3 PCs and one Mac. I have tried the Mac forums and the Windows forums, to no avail.

On the Mac side:

File Sharing is ON, with smb

Users are set to Everyone with read/write privileges

WINS has the correct Workgroup name

Network Name has no spaces in it

Shared my Desktop, Public Folder, Documents, and Shared folders (just to cover root folders and specific ones too)

Mac gives an smb://xxx.xxx.x.x address and a local network accession "mycomputername.local," but I don't know what to do with either of these things. When I put the addresses into the Windows Run dialogue box or in Internet Explorer, they don't seem to recognize the path.

Firewall is set to Allow All Incoming Connections

Under the Shared location in Finder, I can see my router name, and if I click on it, I can connect. No password is required. I am connected as my account name. However, I can't see the PC or anything at all, in fact.

Under the Shared location in Finder, I can see my shared name for my Mac. But I cannot connect to it, probably because I'm connecting from my Mac.

It would be nice to use the smb://DNSname/sharename or the smb://IPaddress/sharename function in the Go to Server window, but I have no idea where to find this information on my PC. Or on the network. Or whatever this is referring to.

On the PC:

Sharing is NOT password protected under Advanced Sharing Options

I am sharing my Desktop and My Documents with Everyone and Guest, and Windows 7 has provided a file://computername/Users/foldername path. However, when I put this into the Connect to Server or Connect to File window, there is an error.

I can click on my Mac computer name in the Network window, but I get the error message that it cannot connect (network path cannot be found, using \\MYMACNAME as the path). This is when my Mac says it is "connected" when I click on the router in Finder's Shared places.

 

Of course both the Mac and the PC have full connectivity to the same network.

Also, I have disabled the internal firewall in the Belkin router.

Also, my accounts have identical names with no spaces.

 

Any advice? Thanks guys!!
 

Question Info


Last updated October 30, 2019 Views 75,084 Applies to:
Answer
Answer

Okay, so the strangest thing just occurred. I reformatted my Mac and installed Snow Leopard (10.6.4), and now it shares fine. Here are my settings:

On the Mac:

Sharing --> File Sharing ON, I shared my desktop and gave Everyone Read and Write privileges. Under Options, SMB is the only thing checked. My account is checked. My Computer Name can have many different kinds of characters in it, including capital letters, spaces, numbers, and even a comma.

Accounts --> The name of my account has a space in it, and capital letters, but that seems not to matter. It is password protected, and has the same password as my Windows 7 desktop.

Network --> Advanced --> WINS has the workgroup name WORKGROUP. The NetBIOS name automatically fills in, I'm assuming because I'm successfully sharing on the network.

Security --> Firewall is set to Allow All Incoming Connections. However, I toggle with Intego's VirusBarrier X6 and if set to Client, Local Server this works as well.

Of course Airport is connected to my home network.

Finder --> Shared Locations sees my router, but nothing else. When I highlight the router, it says "connection failed." This seems not to matter.

My home network has capital letters but no spaces in it.

On the PC:

Network and Sharing Center --> Advanced Sharing Settings --> Current profile is Home of Work. Turn ON network discovery, turn ON file and printer sharing, Turn ON sharing so anyone with network access..., Media streaming is ON,  Use 128-bit encryption, Turn OFF password protected sharing, and Allow Windows to manage homegroup settings.

User name is the same name as the Mac, but without a space. Also contains capital letters. I don't know if a space would be okay or not, or if would be okay if the Windows User Name didn't match the Mac Account name (excepting the space, of course).

Control Panel --> Windows Firewall --> One, set to Home network.

Following previous post, the following has also been performed:

"Win7 Pro/Ultimate only:
Start Orb>Search box>type: secpol.msc
When secpol.msc appears in Results above, right-click it and "run as administrator".

Click on "Local Policies" --> "Security Options"

Navigate to the policy "Network Security: LAN Manager authentication level" and double-click it to get its Properties. By default Windows Vista sets the policy to "NTVLM2 responses only". Use the drop-down arrow to change this to "LM and NTLM – use NTLMV2 session security if negotiated".

In Win7 Home Premium:
Start Orb>Search box>type: regedit
When regedit appears in the Results above, right-click it and "run as administrator"

Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

1. If it doesn't already exist, create a DWORD value named LmCompatibilityLevel
2. Set the value to 1 and reboot."

On the router:

Firewall is disabled. (If I enable the router's firewall, I lose all sharing connectivity!)

Now, with these settings, on the Mac, I go to Finder --> Go --> Connect To Server and type in smb://PCNAME and login as a Guest (my Windows Sharing setting is NOT password-enabled), my Mac will ask me which drive I would like to mount (I selected Users) and voila! My PC is fully accessible through Finder.

Now, with these settings, on the PC I go to Network and voila! My Macbook is listed. The shared folders are browseable.

Whew! My gut says that this is a 10.5 bug.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.