Windows 7 - Ad-Hoc network / computer to computer connection - has got an invalid IP ADDRESS 169:254***:*** how do i change it back to a working ip ADDRESS??

i have being using the ad hoc network on windows 7 since i can remeber last year i got this same problem and got a computer guy to come in to fix it but he failed aswell, but then it just started working again?? and recentily about 2 weeks ago, it has happened again and its driving me insane trying to fix it, I have being into the protocol version 4 on properties and tried putting in my own ip address and dns and things but still 169.254 ip address keeps coming up on my ipod touch 4g (my ipod is working fine i can connect to a router no problem with it) does anyone else have this problem and even better is there anyone, anyone out there who has the answer because it's driving me insane haha, thanks, Thomas John. P.S i have being on system restore and tried to restore to erlier time but nothing happened, many thanks :)
 

Question Info


Last updated June 11, 2019 Views 1,897 Applies to:

169.254 is a valid address range called an APIPA address. Read this article from Microsoft about how APIPA works

 

This is an automatically generated address when the computer does not have a manually set address and when it cannot locate a DHCP server to get issued an address from.

 

For an ad-hoc network this is completely correct. Clients do not have a DHCP server to issue addresses so as an alternative they internally generate one. Assuming all devices are in the same state they will create a network where they can communicate with each other. The last two octets are in principle randomly assigned so the chances of two devices having the same address are small (1:65025) because this solution would not be used in a large network.

 

If you do have a DHCP Server on the network then this is not an ad-hoc network but a client server network. This address appearing indicates the client is not being issued an address from the server which is in most home network cases is the router. You indicate that the iPod gets an address OK but your PC does not so presumably there is a problem with the wired network somewhere.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

thanks very much for the reply, the wired netowrk is working fine i believe because i connect to that through my computer, the way i work my internet is the next door house has an intrnet connection router, and we have a cable from that house to my house because we are out of the routers signal range, before this problem began my ip address was 192.168***.*** i believe and also after i created the ad hoc network i had an extra setting a bar at the bottom, i believe it said allow internet connection sharing or something and all of a sudden that has dissapeared :/ do you know a way i can get it back to how it was 2 weeks ag??????? thanks, Thomas.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Routers act as Dynamic Host Configuration Protocol (DHCP) server. Only DHCP has the capability to provide ip address starting with 192.168.xxx.xxx. In the absence of DHCP, APIPA will be assigned (169.254.xxx.xxx). Whenever you use ad-hoc, there is absence of DHCP, so APIPA is allotted. This is absolutely normal.
Balaji Kundalam

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

OK, there is a little more info here which makes more sense.

 

You have a long LAN cable from your neighbour providing you internet access. This can be no more than 100m long to be within Cat5 spec.

 

I think you have that attached to your wired LAN port and so that port is issued an address from the neighbours router. So at a command prompt if you type ipconfig /all under the wired connection section you should find something like this:


Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : home
   Description . . . . . . . . . . . : Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller
   Physical Address. . . . . . . . . : 00-24-8C-22-C7-EC
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::74ef:2b4c:c42c:a213%10(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.38(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 04 May 2013 11:13:43
   Lease Expires . . . . . . . . . . : 07 May 2013 11:13:43
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 218113164
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-CF-F3-B6-00-24-8C-22-C7-EC

   DNS Servers . . . . . . . . . . . : 192.168.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

 

This is from my system so some precise details will vary but the important bit is Default Gateway, DHCP Server and DNS Server are all the same. Also note that only the last block of the Subnet mask is zero only the same block of the IPv4 address can change.

 

So presumably what you want to do is enable ICS for the wired network and effectively make the wireless port of the PC (a laptop?) a hotspot for your iPod/phone/tablet to get internet access.

 

Then you are correct to define the wireless interface as an ad hoc network but that network does not have a DHCP server on it. Without one the network interfaces on the wireless will issue themselves APIPA addresses as you have found. That should work but with one major caveat. The devices would talk to each other but APIPA is unrouteable so they cannot get to the internet.

 

So instead they have to have manually assigned addresses. In each network interface you have to set the IP addresses, Subnet mask, default gateway and DNS server (except on the PC [laptop?] these are left blank. If using my example above then on the PC you would set:

 

IP Address v4 = 192.168.1.100, mask 255.255.255.0

 

On other clients:

 

IP Address v4 = 192.168.1.101/2/3/4, mask 255.255.255.0, gateway 192.168.1.100, DNS server 192.168.0.1

 

This would mean that your internal clients are on the same network but each with their own address, they use the PC to get out of the network (gateway) but use the neighbours router to resolve the DNS requests.

 

Having said all that this requires that the PC is always available and personally I find the ICS and ad hoc network insecure and unreliable so I would not do this at all.

 

Get a DSL (also called Cable) router with WiFi. Log into it on the LAN side using the wired port and set up its DHCP server to issue addresses in a different subnet to the ones from next door, so if they use 192.168.0 then set it to 192.168.1 (or get one which uses a different range by default) When you save this change you will lose contact but that does not matter at this stage. Plug the long LAN lead from next door into the DSL port. And that's it!

 

Computers plugged into the LAN wired ports will connect automatically. WiFi devices will find the router as an available network. Stable, reliable, secure and not dependant on the PC being on. My son has exactly this in his room. He is an Apple fanboi and the long LAN lead goes to his Airport Extreme (a PowerLAN link actually) and then his Mac Pro, Internet TV, iPad etc. all connect to that.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.