Win 7 unable to connect to map network drive on XP after boot. Clicking on the drive, will work

I tried to search this topic but didn't find the exact scenario I have.

I configured my win 7 machine in a way it should map a drive to a folder in XP. The share works and I can see the files without a problem.

The issue however is related to the fact that after a boot, the share is NOT connected. However, clicking on file explorer and clicking on the map drive, does connect to the remote machine. In other words, I don't need to provide any credentials, just click on the map drive and it will work but I have to always do that manual step. Any way to automatically configure this setting?

 editing:  Believe the following information might be relevant:

1) The drive I am trying to map to is on windows XP machine 2) My "LAN Manager authentication level" is set to "not defined"

The thing that is different in my scenario relative to all the other posting is, that i am not being asked to enter user name and password each time. Its enough that I click on the drive from Windows Explorer and it connects.

 

 

 

Question Info


Last updated March 13, 2018 Views 2,110 Applies to:

I am having interesting problems mapping a drive from win 7 to an XP machine see :http://social.answers.microsoft.com/Forums/en-US/w7network/thread/5dd75f91-d697-4447-a3a2-24ae02301fa2/ for more details on that.

 In my research on the topic, I found resources that suggests my issue might be related to "LAN Manager authentication level" level.

At the moment it is set to "not defined". The moment I will change that setting to something else, I wont be able to bring it back to "not defined" state hence, there is a good chance I will do harm by changing that setting.

Anyone know what the default behavior Win 7 exhibits with "not define" value or a way of resetting it back to "not define" later should I see regressions?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

If you did not configure the Sharing deliberately to avoid security, the something is Not right in the configuration and there is No point to add another iffy solution on top.

If you want an open system and do not need LAN security Enable the Guest account on all computers and give it full permission.
Using IP reservation (if your Router can do it) or static IPs out of the DHCP range can help stabilizing Sharing and Mapping too.

Permission and Security issues, check the followingsettings.

Point to the a Folder that meant to  to be share. Right click and choose properties.

In the properties

Click on the Security tab shown in the pic bellow to the right) and check that the users and their permission (shown in the pic bellow center and left) are correctly configured. Then do the same to the Permission tab.

This screen shot is from Win 7, Vista's menus are similar.

http://www.ezlan.net/Win7/Permission-Security.jpg

In both the Security panel, and the Permission panel you have to highlight each User/Group and examine that the Permission Controls are checked correctly.

Win XP Permission.

http://www.microsoft.com/windowsxp/using/security/learnmore/accesscontrol.mspx#securityTab

When everything is OK, hard Reboot the Network (Router, and computer).

-----------------
* Note . The Groups and Users shown in the screen-shoot are just an example. Your list will look the way your system is configured.

**Note . You have to establish specific users. Everyone means all of the users that already have an account and been established as users. It does not meanEveryone that feel that they would like to login.

 


Jack-MVP Windows Networking. WWW.EZLAN.NET
Jack MVP, Microsoft Windows Desktop Experience-Networking.

www.EZLAN.net

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Jack,

You wrote:

"If you did not configure the Sharing deliberately to avoid security, the something is Not right in the configuration and there is No point to add another iffy solution on top."

I am not sure which question you are answering, the two posts are really two diffrent questions and not sure why they were merged. I didnt say anything about sharing, I was just refering to the security policy setting in "local policy" in Windows 7. Those setting came by default with the new PC (HP). In other posting I saw other users having the same defaults so it wasnt something I set or something I disabled on porpuse. Its possible this is a result of the fact the Win 7 was a Home edition and I upgraded it to unlimitaed.

Again, I have no problem accessing the folder. The issue is only after boot auto connect to the map drive is failing. However when I go to the file explorer, clicking on the "disconnected" drive, I get to access the drive without any prompt for user name and password. It works, it just doesnt work automatically.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

Map is not an idependent process it does nothing on its own.

If the Shares are Not available Map does not work.

 


Jack-MVP Windows Networking. WWW.EZLAN.NET
Jack MVP, Microsoft Windows Desktop Experience-Networking.

www.EZLAN.net

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

Map is not an independent process it does nothing on its own.

If the Shares are Not available Map does not work.

 


Jack-MVP Windows Networking. WWW.EZLAN.NET


I don't understand what you are saying. I am telling you the share works, I can access it and view content on it.there is no problem with the share. That share is mapped to drive Z: . The problem that the map doesn't happen automatically after reboot, I have to manually click on the drive and then it works (just click, don't need to enter any new credentials).

Or say it differently everything works fine my Z: drive. It can access the other machines just fine once I do that manual step after reboot. For what ever reason, at boot time

 

Update: I tried to set the same drive map on another Win7 Ultimate machine on the same network, pointing to the same share as mentioned above and it works without a problem.

That means, the problem is not on the XP side or the share side, there is something different on this particular machine setting relative to the other one.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Givemeabreak,

Any chance your Windows 7 PC is connected to a wireless network? If the network connection isn't established immediately, the mapped drive won't connect on startup.

May also be worth updating your NIC driver via the manufacturer's website if you're not on wireless.

Hope this helps!


Cody C
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.
Instead of telling our young people to plan ahead, we should tell them to plan to be surprised.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Cody,

Thanks for your interest in my case. I can confirm that the machine at hand is not connected via a wireless connection. Its a relatively new machine (early 2010) which I maintained with all the updates.

The only thing I find "special" about this machine is the fact it was upgraded from Win 7 home which seems to have different features around authentication pointing to issues related to "LAN Manager authentication level" -

From what I read somewhere, the home edition doesn’t all the authentication features(http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/91fe4e10-a0d4-45db-94df-fad885d8f64f)  Win 7 Ultimate might have so in the upgrade process, it appears no setting were placed to the "LAN Manager Authentication Level" - it shows the value of "undefined".

I am hesitant in playing with that setting not knowing how to revert those back to "undefined" should this not work.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Givemeabreak1,

I haven't had the LAN Manager Authentication Level affect sharing issues in the past so I'm hesitant to recommend changing that at all.

Lets try and find a working point...try performing a clean boot to see if a third party tool is possibly causing this:

http://support.microsoft.com/kb/929135


Cody C
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.
Instead of telling our young people to plan ahead, we should tell them to plan to be surprised.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.