Win 7 Remote Desktop and Local Printing Not Working

I am having trouble using a locally networked printer when I use Remote Desktop to connect to a Vista machine.  Under the local resources tab for RD, I have checked printers.  The only thing I can figure is that my printer is networked locally, not connected directly to my machine.  Every time I try to print during my remote desktop session, I can't access my locally networked printer.

I installed the printer drivers on the remote computer and when I try to locate the printer, I get the following error: "Windows cannot connect to the printer.  Server print spooler service is not running..." but the spooler service IS runing.

Any advice would be greatly appreciated.  I've spent a few hours on this one and am at a loss at this point.

UPDATE: I tried to plug in my printer to a local USB port this morning.  Still would not work.  I keep getting the same spooling error.  The drivers are not corrupt, as others have indicated may be the cause.  They work fine on my system locally with 7.

I also found a post elsewhere that discussed setting 'share permissions' and 'network permissons' to resovle the spooler error.  Still no go.

Please help.  I really need to print locally.
 
Question Info

Last updated August 10, 2018 Views 165,351 Applies to:
Answer
I finally figued it out after four days and many hours on the phone with Microsoft.  Microsoft claimed that it was related to my router settings, but I didn't believe it since the remote computer saw my iPhone just fine when it was connected locally.  After simply playing around, here's what I found...it was quite basic!

On the remote system, when you try to add a 'local' printer, there's a drop down menu with a list of local ports that your remote system sees.  Some of those will be on the remote system, but others will be on your local system.  Make a note of the ones that are seen on your local system.  In my case, LPT1 was not visible, but COM3 was.

Next, on your local system, in the settings for your functioning printer (Printer Properties, Ports Tab), there's a tick box that says "Enable Printer Pooling."  Once you check that box, you can select multiple ports on your local machine.  Here, you need to tick the box that your remote system is seeing (in my case, it's COM3), but make sure that your exisitng port remains checked as well (in my case, an IP port for my wireless router).  Basically what you're doing is on your local system, you are pooling your exising printer setup with a port that can be seen by your remote system. 

Then, on the remote system, install the printer drivers but don't select a port.  Then go into Printers and add a printer.  Select 'local' setup for that and when asked for the port, use the port you checked in the previous step on your local system (in my case, I selected COM3 on my local system).  Select your printer from the list.  It will ask if you want to use the exisiting drivers...say yes.  Then print a test page to be sure that it works.  Worked fine for me.

I simply can't believe how obvsious that solution was!  If the remote system can't see the port you currently use, pool your setup with a port that it can see!

81 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.