WiFi very slow to reconnect (if at all) after sleep or hibernation

Hello everybody, I have seen similar threads on this topic before but none of the proposed solutions have worked for me. I am unable to connect to any WiFi after my laptop returns from a low power mode (sleep or hibernation) for sometimes lengths of time up to 2 minutes. Either an orange star/circle shape is shown in the system tray on the wireless icons saying network connections are available, or the spinning progress icons rotates endlessly and never connects. If I want to reestablish network connection, I have to restart my computer, or disable and re-enable the wireless adapter (Intel WiFi Link 5300AGN).

 

Things I have tried to remedy the problem:

  • Uncheck "Allow the computer to turn off this device to save power" under Power Management in the Wireless Adapter's, AND USB Root Hub device properties
  • Switch my Power Plan to High Performance and set Wireless Adapter Settings to "Maximum Performance"
  • Enable the blank Screensaver and disable turning off the display (suggested on a forum I found)
  • Uninstalling Virtualbox (suggested on another forum I found)
  • And I've tried every driver I could possibly find for my card to no avail

If it helps any, I'm running Windows 7 Home Premium on my Dell Stdio XPS 1645.

My guess is that even though the wireless card is told (in more ways than one!!) not to turn off or sleep, it does so anyway. Is there another option I'm missing somewhere?

I've had this issue for months now it's becoming increasingly frustrating. I would really like to avoid starting fresh with a new installation of Windows... Any suggestions?

Thanks!

-Jackson

 

Question Info


Last updated April 18, 2019 Views 63,378 Applies to:
Answer
Answer
Ok I was able to fix my issue. I went into device manager ---> network adapters and I just right clicked the Wireless adapter and selected uninstall. I also had two Microsoft Virtual Wifi Miniport Adapters. I removed those two as well.. I rebooted and presto I tested it 3 times. I put my computer to sleep and when it woke up the connection was still there! It's funny because after I removed the Wifi adapter and the 2 MS Virtual Adapters and rebooted and went back into device manager there was only one entry there now for the MS Virtual Adapter. Not sure if this will solve your issue but it solved mine!

46 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Hi

Nice work on trying to get it going.

-------------------------------

A general comment .

We all have a general problem. There are many 3rd party applications that when installed and used insert themselves into the Network components of Windows, some of them also alter the default of the configuration. Most of these applications are Not thoroughly test. They are tested to work but usually it is on some simple standard system. it does not tested and take in account the hundreds of iteration of End-Users Network configurations with its wide variety of Hardware and other Network related applications.

Among these applications are 3rd party security suits, Network Managers, 3rd party network related wizards, Virtual applications, users playing around with settings found over the Internet with limited info about what they actually do, and many more.

To complicate the issue, some of these applications load process at startup and interfere with the Network even if the application is Disabled, or and Uninstalled.

I found rather known 3rd party Network application that use to leave around 100 entries in the registry, and an Undelete-able icon on the Desktop after it is Uninstalled.

As sad, as it is at times the only functional solution is Re-Install of the OS to brink it back to standard status.

-------------------------

As for Power Saving there might be more settings.

Look at the Laptops BIOS too, some of them have hardware embedded scheme.

Also look at the StartUp and Processes to make sure that there is no 3rd party utility involved in the WIFI mangement.

This can help to find out.

StartUp & Process Explorer   - http://www.ezlan.net/infestation.html#startup  

------------------------

Assuming that the signal is strong, and that there is No electrical environmental noise.

Check the Computer's support site and make sure that you are using the latest Drivers*** for the Network cards.

Check the Router's support, and make sure that your using the latest firmware for the Router.

Uncheck the Network Card's Power Saving (I.e., do not let the card save power).

There might be some variations on where the Power saving setting is.

Here are few examples, YMMV, look around in your systems.

Example, http://www.ezlan.net/example/powersave.jpg

Example, http://www.ezlan.net/Win7/power_sav_wireless..jpg

Example, http://www.ezlan.net/Win7/power_save_win7.jpg

Example, http://www.ezlan.net/Win7/adv_power-sav.jpg

***On  Drivers Update .

Try to install the latest drivers of the card from the support page of the  manufacturer.

Download the drivers and unpack them to a folder of your choice.

In the Device manger, right click on the adapter.

Click on Update Drivers, and choose the Browse my computer for drivers,

Choose let me pick from a list, Click on  Have a Disk and point to the folder with the Drivers.

 ----------------------------

When your are done with whatever you did run this.

WinSock and TCP/IP Refresh.

Type Cmd in the Start Search text box.

Press Ctrl-Shift-Enter keyboard shortcut to run a  Command Prompt as an Administrator.  Allow elevation.

Type netsh winsock reset in the Command Prompt , and then press the Enter key.

Do the same process for refreshing the TCP/IP just replace the typed command with.

netsh interface ipv4 reset
  press Enter

netsh interface ipv6 reset
  press Enter

ipconfig /flushdns
  press Enter

Restart your Computer.


Jack - Microsoft MVP, Windows Networking. WWW.EZLAN.NET
Jack MVP, Microsoft Windows Desktop Experience-Networking.

www.EZLAN.net

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.