WiFi downloads are to slow in win 7 pro 64bit, IT MUST BE win7pro or driver settings !

Some times something is reset and bandwidth goes to 13-14 Mbps
Then it starts shrinking until it gets to less than 1 Mbps.
Then I delete the wireless adapter (but not driver sware) in device manager and reboot.
Then I'm back to 3-4 Mbps.
I've tried netsh int tcp to disable heuristics, autotuning and forcing ctcp.
Doesn't matter which hotspot.
I've tried TCPOptimizer.
System is a Dell N5110 with an Intel centrino N-1030 wireless adapter.
Some setting is being altered and I have yet to figure out what !
So far, I am absolutely sure it is not the hardware, not the hotspot, not Newsbin v5.5 that is squeezing my bandwidth.
It simply must be win7 or the driver for the wireless adapter.
And no, I do not have a system recovery point where it is ok. If I did, I would have figured out the problem already !

|
Answer
Answer

Resolved: Windows 7 64 bit slow loading certain web pages, browser independent

 

I had a similar problem on a wired connection:

 

1) After cheking my NIC, router, modem etc. determined no fault. Tried IE, FF, G Chrome; does not matter!, and extremely slow loading on affected pages, ( looking at network traffic in task manager - network tab) . These pages eventually load after a long time (sometimes minutes). This is inspite of the fact that the dowload/upload speeds to the ISP were routinely tested to be within accptable limits. 17 mbit/s down / 0.5 up.

 

2) Numerous threads on google searches suggested complex diagnostics and operations that appear to make no difference, including reloading the OS. Too much trouble for me.

 

What finally worked for me: (Before you completly go bonkers on a dissassemly/reloading the OS rampage)

 

Back to basics: Suspected some component installed in the OS to the responsible.

 

1) Started OS in safe mode, using msconfig.exe command, with networking on. Problem dissappeared! Pages now loaded at Nitro speed! But no other functionality.

 

2) To get a functional computer back, you need to do a selective start-up in msconfig.exe. Select the services tab and uncheck all the services. (Safe mode will uncheck them all, except for essential ones + security). The trick is to proggressivly turn these services back on in smaller groups, reboot, test your web page loading speed each time, until you find the offending service.

 

The service that caused the problem on my machine was the windows managenent intrumentation.

I have this unchecked at the moment and it does not appear to affect functionality so far. I will look further into resolving the issue with this service (WMI), but I am back up to speed.

 

For now, I am running a selective start up with only this (WMI) service disabled. W7 remembers this startup automatically next time you turn on your machine.

 

I hope this information will serve as a possible course of action for others unhappy with their webpage loading times.

 

HandyAndy

 

 

 

 

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated March 13, 2018 Views 542 Applies to: