VERY SLOW (<200kb/sec) File Copy between Win7 Machines Over 300Mb Wireless Network

Hi All,

This problem has been driving me crazy for over a week now, and I would really appreciate some help.

I have a PC running Win7 Ultimate connected to my 300Mbps Wireless-N network in my office.  This machine connects to the network just fine at 104Mbps (card limitation) and can copy/transfer files to/from our file servers over this wireless-n network at 12-15Mbps.  Works perfectly, and I have really been enjoying Win7!!

I've just added a new ZINO HD (Dell Inspiron 400) with a Dell 1520 802.11 b/g/n wireless NIC running Win7 Pro which connects to the same wireless-n network at 216Mbps (according to the "Network and Sharing Center").  However, any files that I copy/transfer to/from the ZINO from/to the Win7 Ultimate PC or our file servers move at speeds ranging from 54Kbps to 972Kbps, and the rate sometimes goes up and down during the copy/transfer.

I have no problems with the speed of files downloaded/uploaded from/to the Internet from the ZINO over this same wireless network.  The ZINO has 5-bars on the connectivity. 

I have tested to make sure that all of the ZINO drivers are the latest and operating correctly.  I have also played with a number of various settings on the ZINO NIC with no change, and tried various router (Linksys WRT150N) settings without luck.  I have tested with the firewall(s) on and off and tried a number of other suggestions I've found on various forums, all to no avail.

Thank you in advance for any help you may be able to give.

 

Question Info


Last updated October 30, 2018 Views 38,246 Applies to:
Answer

Hi All,

OK, my team has found a solution to our problem.  Here are the steps:

1. Running as Administrator in Command Prompt, type: "netsh int tcp set heuristics disabled"

2. Next, follow the instructions that Amrita wrote above. 

                  First enter: "netsh int tcp set global autotuninglevel=disabled" and reboot.

                  Then enter: "netsh int tcp set global autotuninglevel=normal" to restore it to the typical setting.

3. Finally, go to Control Panel > Programs > Turn Windows Features on or off > and check "Simple TCPIP services (i.e. echo, daytime, etc.) so that it is enabled.

4. Reboot your system again, and the file transfer rates should be excellent.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.