Unable to connect to company wireless network after Win7 upgrade

My company network does not broadcast the SSID, so on Vista I used to manually setup the connection.  However with Win7 64 I keep getting an error that "An unexpected error has occurred"

Dell xpsM1330

Intel WiFi Link 4965AGN

Any help would be appreciated.  

|
Answer
Answer

Ok, let's see if we can keep this active and get to a fix...

Got an MS POC to give me some info that may help....

I've experienced what many above have, that while I can connect to most wireless networks, including my home wpa2, any time I tried to make a connection my corporate wpa2-enterprise network, no go, and had the errors in the event log. also similar failures whenever I'd try to create any wireless profile manually using wpa-enterprise or wpa2-enterprise.

Note mine was also a machine that got USMT data migrated, and I have a feeling it was responsible for migrating the keys below...

So here was the final fix, and maybe you guys can verify if it's the only thing needed as I'd tried various other things to no avail, but this was the "last" change I made that got things working...

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\RasMan\PPP\EAP

under here are a number of subkeys with different numeric values....

while I can't tell you specifically what to look for, in my case I noted there was one key pointing at what I'd expect, a ras related key in the windows\system32 dir. however, I also had three other keys pointing to files related to Symantec, which I did not have on my newly built machine.

So I exported keys from a newly built machine, that actually had symantec. it had four keys under EAP, but only one, the last one, was related to Symantec, all others pointed to files in system32.

I imported those keys into my broken machine, deleted the one key that was related to symantec, and without even having to reboot...all was fixed...

so....here's my suggestion, and I hope if this works everyone can feedback so we have more info on if it's the order of the keys or just the presence of bad entries...but I would suggest, starting off by looking at your keys under EAP, and seeing if there's anything referencing dll files that may not exist on your machine.

if you do have these keys, either delete the key, or try to put the file back in place thats being referenced, assuming it's missing.

we'll be doing some more testing internally, so I'll feed back if we have any additional findings.

good luck.

19 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated June 16, 2020 Views 62,668 Applies to: