Unable to connect Internet - DNS error - Windows 7

Hello,

I have a new (3 months old) Dell XPS Desktop Computer with Windows 7 (64-bit), the Motorola SBG6580 Wireless Modem/Gateway, and Comcast is my ISP.

My computer is connected to the modem with an Ethernet cord. I don't have anything unusual about the setup. I just plugged in my PC and it worked.

For the past three months everything was working fine. Then all of a sudden, as of last Friday I can no longer access the internet.

The Connection icon on the bottom right is showing that I'm plugged in, and every few minutes a yellow exclamation mark pops over it. Some websites open very, very slowly, some don't open at all, and other just give a straight up error that I'm not connected. It's weird - I can connect for the first few seconds when I re-start the computer, and the speed is extremely fast, and then all of a sudden I can't connect.

When I right-clicked on the connection icon to troubleshoots sometimes it says "The DNS isn't responding" and other times it can't detect any problem (but I still can't access any websites).

Now, I also have two game consoles connected with Ethernet cords to the modem and they're working fine - I can get online, play games, stream movies etc. My wife and I can also connect our iPhones over Wi-Fi, and I can also connect my laptop running Vista over Wi-Fi.

The problem is just the Windows 7 PC.

I've already googled the problem and tried every solution offered - I flushed and renewed the DNS using the ipconfig commands, I set the DNS manually but nothing seems to work!

Could this be a virus of some sort? I have McAfee running, and I performed a scan but it doesn't detect anything. My gut feeling is that there's a virus that's changing the DNS.

Any suggestion on how I can confirm, or what other steps I can take?

Thanks!

 

Question Info


Last updated November 18, 2018 Views 133,175 Applies to:
Answer
Hello,
 
Perform steps mentioned below and check if the issue persists.
 
a:  Click on Start and then Control Panel.
b: Go to Networking and sharing center and then click on Change adapter settings.
c: Right click on Local Area Connection and choose properties.
d:  Highlight Internet Protocol Version 6 and click on Properties.
e: Choose Obtain DNS servers address automatically and press Ok.
f: Choose Obtain IP address automatically.
g:  Repeat the steps for Internet Protocol version 4 as well.
 
Hope that helps.

158 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.