System error 85 has occurred The local device name is already in use only occurs on x:\drive hosting offline files

Hi I have a very annoyed CEO that complains about receiving error message: System error 85 has occurred The local device name is already in use intermittently when logging on. Running the logon script manually (copied logon script to desktop) also gives the error message when this occurs.  We make use of a the following logon script:

 

net use * /delete /y

net use X: \\ServerName\users\%username%

net use Y: \\ServerName\shares

 

The X:\drive (pointing to: \\ServerName\users\%username%) hosts offline files for the CEO The problem only affect the X:\drive and I suspect that it is due to the offline files because when he is working offline the X:\drive is still mapped. How can I resolve the error or does he have to deal with this when using offline files? His AD profile home folder also connects X: to \\ServerName\users\%username%

 

Thanks for the help in advance.

 

 

Question Info


Last updated February 24, 2019 Views 23,020 Applies to:
Answer
Hello kellamd,

Which operating system is installed on your computer?

This issue can occur if the drive letter that is being mapped by the net use command is already mapped in the user's properties.

a. Use net use /persistent:no in the logon script.
b. Add "net use * /d" command line in the top of the logon script so that the script will clean the all old mapping first.

Regards,

Savan – Microsoft Support.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.