svr Error 2017. Windows XP cannot connect to shares on Windows 7.

XP workstations after a period of time are no longer able to connect to Windows 7 shares until the Win 7 machine is rebooted.
Running time 12-24 hours before problem the arises.
Only Windows XP workstations are affected. Networking or permission errors are displayed on the Win XP machines as they are unable to reference the shares on the Windows 7 PC. However we can still ping IP of the Win7 PC and connect to MySQL running on the Win7 PC.
We are running a Windows 7 64 bit PC as a file sharing server with 4 GB memory. Network has 4 Windows 7 workstations and 3 Windows XP ones.
3 folders off the root directory on the Windows 7 PC have been shared by Right clicking on folder, selecting Share with, then Specific people.
Set so 'Everyone" has Read/Write access. So security is set to Full Control for Everyone on the shared folders.
When a Windows XP system fails to connect to a share, all other Windows XP systems follow suit. Windows 7 Workstations are not affected.
Found errors on the Windows 7 (file server) system logs that occur at the same time as the problem and is repeated many times:

Source:        srv
Event ID:      2017
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      SERVER01
Description:   The server was unable to allocate from the system nonpaged pool because the server reached the configured limit for nonpaged pool allocations.

I have found some references that relate to this error for Vista 64 bit suggesting to disable SMB2 in Registry and/or change MaxNonPagedMemoryUsagein registry from 1 to 3.

I am just hoping to find out something more definitive.

 

Question Info


Last updated October 30, 2019 Views 13,916 Applies to:
Answer
Answer

Hi

There is controversy whether changing the setting of the "LanmanServer\Parameters\Size" cache works on Win 7.

As far as my experience goes, it seems to help on a Win 7 computer that is used as Hi traffic server.

Try to do this.

Set the Dword value of the following registry key to 1

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

Set the Dword value of following registry key to 3

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size

If it does not do anything, you can leave it as is, or reverse the settings.

 


Jack-MVP Windows Networking. WWW.EZLAN.NET
Jack MVP, Microsoft Windows Desktop Experience-Networking.

www.EZLAN.net

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer
After reading a number of posts, I have made the following adjustments to my Windows 7 PC (file sharing server).

Changed: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache - Set it to 1  (was 0)

Changed: HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size - Set it to 3  (was 1)

Added: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\MaxNonpagedMemoryUsage - Set to 0xFFFFFFFF

Also changed:
Advanced System Setting --> Adnavnced --> Performance (settings) --> Advanced - Set "Background Services" option.

I am monitoring this system and will post results after a number of (working) days.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.