[SOLVED] No network access (no wireless internet) with WPA-2 after clean install of Windows 7

I just did a clean install of Windows 7 onto my HP Touchsmart desktop. While the installation went fine, the computer is unable to connect to the internet. The computer says that it is has "No network access". I have a separate laptop that has Windows 7 and is connected to the internet just fine, so the problem appears to be with the settings on the desktop computer that is preventing it from properly connecting.

For reference, I have a Linksys router and this is an HP desktop computer. My router connection is protected with a WPA-2 password, but when I enter in WPA or WPA-2 keys onto the computer, it says that "The settings saved on this computer do not match the requirements of the network."

When I click on the wireless icon in the tray in the right hand corner, it says that the computer has connected to the wireless router with the name "Linksys" and has "Limited access". When I right click and go to Status, it says that there is "no network access" for IPv4 Connectivity and "no network access" for IPv6 Connectivity.

Any help would be appreciated. I will reply with the results of each suggestion.

Thank you!
Shana
 

Question Info


Last updated December 11, 2018 Views 4,142 Applies to:
Answer
Answer
Hey everyone, 

I finally fixed it! Apparently this is a problem with Windows 7 on 64 bit machines. Apparently it does not detect WPA and WPA-2 connections, which makes it impossible to connect to the internet. When I would hover over the connection name, it would state that it was a WEP connection, even though this is false. 

First I took the advice of some others on the internet and uninstalled and reinstalled both my Wireless card and my Ethernet NIC card drivers. Even after doing that, however, there was no change, so this is NOT a solution.

Here's how I ACTUALLY fixed it:

Example: Lets say that the name of my wireless network is "cheese", it is protected by a WPA-2 Personal  AES password of "cheddar."

1. Open Network and Sharking Center
2. click Set up a new connection or network
3. click Manually connect to a wireless network
4. enter in "cheese" as the network name; select WPA-2 Personal for the Security Type, AES as the encryption type; and type in the Security Key "cheddar".
5. Check the box for "Start this connection automatically"
6. Check the box for "Connect even if the network is not broadcasting" <<<---I suspect this is the most important step.
7. Hit Next, continue through all the screens. Voila! You should be connected to the internet.
8. Restart the computer.

You should now automatically connect to your WPA-2 protected wireless connection every time you turn on your PC.

The little bars in the corner of my screen which show the wireless connectivity sometimes randomly show a red X as though it's not connected, but it IS still connected to the internet and working just fine. Basically, the connectivity thing in the corner is useless and will say you're not connected, but you are.

Hope this helps!

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.