Sharing files between a Windows XP PC and a Windows 7 PC over a home network

I have files on an old PC running Windows XP that I would like to get onto my new PC running Windows 7. I have been trying to access the files over the network the same way that I always had with XP, by making them available over the network through the folder's properties.

I have made the files available for sharing on the XP computer, but can't figure out how to access them from the new Windows 7 PC.

PC with desired files is running Windows XP
PC to retrieve files is running Windows 7
The XP PC is connected wirelessly through a Linksys router
The W7 PC is connected to the same router via Ethernet cord
 

Question Info


Last updated June 8, 2019 Views 348,030 Applies to:
Answer
Answer
Hi All!

This problem occurs if the Link-Layer Topology Discovery (LLTD) Responder component is not installed on the Windows XP-based computer.

In order to establish the connection between the windows 7 machine and XP machine, try downloading and installing the Link-Layer Topology Discovery (LLTD) hotfix. Check the link mentioned below:

Link Layer Topology Discovery (LLTD) Responder (KB922120)

http://www.microsoft.com/downloads/details.aspx?FamilyId=4F01A31D-EE46-481E-BA11-37F485FA34EA&displaylang=en

If this doesn't help, can the computer ping each other?

To do this:
  1. Get your computer name (Visit http://windows.microsoft.com/en-US/windows-vista/Find-your-computer-name for help getting your computer name). In this example we'll be using Computer1 and Computer2as the computer names.
  2. On Computer1, Click Start, type cmd and press Enter
  3. In the black and white command box, type ping Computer2 and press Enter

You should get something similar to the following:

 Pinging <###.###.###.###> with 32 bytes of data:

   Reply from <###.###.###.###>: bytes=32 time=77ms TTL=28
   Reply from <###.###.###.###>: bytes=32 time=80ms TTL=28
   Reply from <###.###.###.###>: bytes=32 time=78ms TTL=28
   Reply from <###.###.###.###>: bytes=32 time=79ms TTL=28

If you get Request Timed Out, there's a something blocking communication between the computers.

Try those steps out and let me know what works!


Cody C
Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.
Instead of telling our young people to plan ahead, we should tell them to plan to be surprised.

9 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer
Easiest way, make both workgroups the same . windows key + pause under computer. Kill password sharing in windows 7. Right mouse on the LAN in Win7, open network / change advanced. Select turn off password sharing. Make sure turn network discovery and file sharing are on.

Create a folder in XP share it. Tick simple file sharing if its off (my computer / tools / folder options / view). . Create a folder in Win 7 right mouse / properties  / sharing / share. Select everyone up the top, change the bottom to read/write. Saves you mucking around with passwords, or entering ips in to get into the other folder. To make things easier if you want to copy install files etc. Go to start/run in win7, type shell:sendto, right mouse / new shortcut. Go to the networked folder add it. Then it'll appear under the send to context menu. Do the same with XP, except type sendto under start/run. And do the same thing

If you dont have any other Win7 pc's kill homegroup. Computer, highlight homegroup / right mouse / change homegroup settings / leave homegroup

If any firewalls are installed on either (besides windows), configure them

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.