setting a direct crossover ethernet connection as trusted

I've been having this problem with trying to connect using a crossover connection between a bunch of computers with a partial mesh. it's kinda hard to explain, so i'll draw a little diagram before explaining what i'm doing and what my problem is

A---C
|
|
B
(the connections are crossover connections directly between the computers)

Computer A is an old 2000 computer that I don't really use that much now, so pretty much just used for backup and browsing.

Computer B is my windows 7 computer.

Computer C is an old windows 98, and I set it up with the primary goal of being storage. It has more room on it's harddrive since 98 doesn't really use much for typical OS stuff.

I know you don't care about the story, but if you understand my setup and what's going on, it'll better explain what i'm trying to do and what my problem is.

I'm trying to back up computer B so I can reformat it (since it's acting really sluggish, and unfortunately a clean format is the only solution), and computer A has enough PCI ports for the NIC's, but B and C don't so A has to act as a hub to transfer files from B to C.

My problem is this: windows 7 (computer B) lists the crossover connection as untrusted, meaning that A cannot access B's files to put them onto C. (however, B can access A) How would I disable that and allow A to directly access B's files?

 

Question Info


Last updated April 19, 2019 Views 2,630 Applies to:
Answer
Answer

Windows 7 can identify a network as PublicHome , or Work . The Windows Firewall identifies Home  and Work  as private  networks.

I think there's a bug in the identification logic, because it identifies a crossover cable connection to another computer as Public , just like a connection that goes directly to the Internet.

Here's a kludge that can get around the bug and make the connection private :

  • Assign a static IP address to each computer's LAN connection.
  • Specify the other computer's IP address as the default gateway.

For example:

   Computer A: IP Address = 10.0.0.1, Subnet Mask = 255.0.0.0, Default Gateway = 10.0.0.2
   Computer B: IP Address = 10.0.0.2, Subnet Mask = 255.0.0.0, Default Gateway = 10.0.0.1


Boulder Computer Maven
Microsoft Most Valuable Professional
Steve Winograd

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.