Remote Desktop - Windows 7 Shortcut Keys Don't Function

I connect to my Windows 7 box from my Vista machine via remote desktop (full screen mode, so alt tab works, etc.)  However, the new Windows 7 keyboard shortcuts go ignored (Win-up arrow, Win-number keys, etc.)  They work fine when logged into the Windows 7 machine locally of course.

Is there a fix for this?


Jeff M Axelrod
 

Question Info


Last updated June 29, 2019 Views 12,866 Applies to:

Hi Jeff,

 

 

Try changing the Local Resources settings when you are connecting to the remote computer to “On the Remote Computer”

To change settings

1.       Open Remote Desktop Connection

2.       Click on Options to get more options while connecting

3.       Go to Local Resources

4.       Under Keyboard tab change the setting to ‘On the remote computer’

5.       Apply the settings and then connect to the Windows 7 computer and check if the keyboard shortcuts on the remote desktop works

 

 

Hope this information is helpful.

Amrita M

Microsoft Answers Support Engineer
Visit our Microsoft Answers Feedback Forum and let us know what you think.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for the suggestion Amrita.  The setting to apply Windows key comibnations on the remote computer was already in place.  That was the first thing I checked when troubleshooting, so this is not the problem. 

I believe the problem may be because I've read that for some odd reason the Windows 7 keyboard shortcuts are dependent upon Aero being enabled?  This seems ridiculous.  If this is true, is there a way to enable Aero via remote desktop from Vista Home basic?  I'm not thrilled about having to do this even if it's possible, as my remote desktop is usually over a slow network connection.

I assume this problem should be readily reproducible by Microsoft staff.  I assume this is a defect in Remote Destkop?

 


Jeff M Axelrod

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Does nobody at Microsoft know how to solve this problem?  It's easy to reproduce.
Jeff M Axelrod

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If you change to "Under Keyboard tab change the setting to ‘On this computer'" inAmrita M comment regular windows shortucts (alt+tab) will work on your pc where remote destop shortcuts (e.g. alt+page up) will work on remote desktop.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.