Remote desktop sessions fail with data encryption error

All my attempted Remote Desktop sessions fail with some bull*** data encryption error. It seems half the world has that error and no one can provide an answer. Before you link to a worthless answer, it's all my customers servers with every thing from Windows Server 2003 - 2011, can't RDP to any of them anymore.

Most suggested answers address a particualr server issue or router issue or suggest disabling large offload on the NIC.  Well this issue happens accros 30+ servers I have tried lately.  I've tried with Offload set to disable, and set to enable.  I've tried ethernet and wifi.  I've tried doing it from different internet connects, work, home various customer sites.

 

Put simply, I can no long use RDP to connect to ANY servers on ANY connection.  It simply does not work anymore.

 

I run Windows 7 32-bit and this just suddenly couple of days ago.  Before you start, no viruses, no updated drivers...blah blah blah.

 

The first day it started it wouldn't let me RDP over VPN but would if I went in through the external IP (mapped ports).  Then it would only work if I was on ethernet, not on wireless.  Then it just decided it wouldn't work at all.  Today I even tried to get back into work remotely via RWW, and the RDP ActiveX....did not work.  Tried two servers a 2003 and a 2008 SBS.  Nope.

XP had a ten year plus lifespan.  Win7 has just about made it to three years, now it starts to fall to pieces.

If you can fix this before I upgrade to Windows 8, and without having to wipe my entire PC, it would be much appreciated.

 

Question Info


Last updated August 8, 2019 Views 1,870 Applies to:
Answer
Answer

Hi,

The issue you posted would be better suited in the TechNet Forums. I would recommend posting your query in the TechNet Forums:

http://social.technet.microsoft.com/Forums/en/winserverTS/threads

 

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.