PC/Laptop won’t connect using Homegroup

I have tried to setup a homegroup but my laptop will not connect to my desktop. The homegroup is on the desktop but I have tried it using the laptop as the homegroup computer and no connection that way either. I can however connect both ways as a network. Anyone else have this problem and if so how did you correct it?


Question Info

Last updated October 30, 2018 Views 6,210 Applies to:


Quote:" I can however connect both ways as a network".  Homegrouo is a Network too.


Sharing entails.

1. All the computers on the same Network.

2. Firewall and other software security configured correctly to allow Local Traffic.

3. File/Printers Configured to Share.

4. Permission/Security set for all Users.


Win7 when configured on peer-to-peer Network has three types of Sharing configurations.

HomeGroup Network = Works only between Win 7 computers. This type of configuration makes it very easy to Entry Level Users to start Network sharing.

 Work Network = Basically similar to the previous methods of sharing that let you control what, how, and to whom folders would be shared with.

 Public Sharing
= Public Network (like Internet cafe) to reduce security risks.

 For best results log to each computer's System Screen and set all the computers to be on a Network with the same name while each computer has its own unique name.


Make sure that the Software Firewall on each computer allows free local traffic. If you use 3rd party Firewall On, Vista/XP Native Firewall should be Off, and the active Firewall has to adjusted to your Network IP numbers on what is some time called the Trusted Zone (consult your 3rd Party Firewall instructions

General example,  http://www.ezlan.net/faq.html#trusted

Please Note that some 3rd party Software Firewalls keep blocking aspects of Local Traffic even it they are turned Off (disabled).
If possible configure the Firewall correctly, or totally uninstall it to allow clean flow of local network traffic.

If end up with the 3rd party software uninstalled or disabled, make sure that Windows native Firewall is On .


If your network is comprised of Win 7 only and you want a simple Network, use this.


HomeGroup-recommended-links - http://windows.microsoft.com/en-US/windows7/HomeGroup-recommended-links

HomeGroup-frequently-asked-questions - http://windows.microsoft.com/en-US/windows7/HomeGroup-frequently-asked-questions

After configuring the Homegroup scroll down to the Permission/Security section.


Networking Win 7 with other version of Windows as  Work Network (works very well if all computers are Win 7 too).

In the Network Center, clicking on the Network type opens the window to the right.

Choose your type of Network. Notice the check mark at the bottom, and check/uncheck it according to your needs.


Win 7 - http://windows.microsoft.com/en-us/windows7/Networking-home-computers-running-different-versions-of-Windows

Win 7  Work Network specific folder sharing - http://www.onecomputerguy.com/windows7/windows7_sharing.htm

Vista File and Printer Sharing- http://technet.microsoft.com/en-us/library/bb727037.aspx

Windows XP File Sharing - http://support.microsoft.com/default.aspx?scid=kb;en-us;304040

In Win XP Pro with simple sharing Off,  you can Visually see the Permission/Security setting , and configure them to your liking.


Printer Sharing XP - http://www.microsoft.com/windowsxp/using/networking/expert/honeycutt_july2.mspx

Windows Native Firewall setting for Sharing XP - http://support.microsoft.com/kb/875357

Windows XP patch for Sharing with Vista (Not need for XP-SP3) - http://support.microsoft.com/kb/922120

When finished with the setting of the system it is advisable to Reboot all the hardware including the Router and all computers involved.


If you have Permission and Security issues with Vista/Win7, check the following settings.

Point to the a Folder that meant to  to be share. Right click and choose properties.

In the properties

Click on the Security tab shown in the pic bellow to the right) and check that the users and their permission (shown in the pic bellow center and left) are correctly configured. Then do the same to the Permission tab.

This screen shot is from Win 7, Vista's menus are similar.


In both the Security panel, and the Permission panel you have to highlight each User/Group and examine that the Permission Controls are checked correctly.

When everything is OK, Reboot the Network (Router, and computer).

* Note . The Groups and Users shown in the screen-shoot are just an example. Your list will look the way your system is configured.

**Note . All user that are allowed to share need to have account on the computers that they are allowed to connect to.Everyone is an account, it means a group of all of the users that already have an account and been established as users. It does not mean Everyone that feel that they would like to login.


Jack-MVP Windows Networking. WWW.EZLAN.NET
Jack MVP, Microsoft Windows Desktop Experience-Networking.


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.