Network problem between Win XP and Win 7 machines

I have 2 machines, one desktop and one laptop.  The desktop is running Win 7 Pro (installed on 1/1/2010) and the laptop is running Win XP Pro.

The desktop (Win 7) can see the laptop (XP) on the network and can access the shared folders. 

However, the reverse is not quite true.  The laptop can detect the desktop as a network computer.  I can double click on the icon and see the desktop folders that are shared.  But when I try to access the contents of the folders I get a message that says I don't have the necessary permission and to contact the system administrator.

I also have a problem with the shared printer (connected to the Win 7 desktop).  Before the upgrade both machines could print, after the upgrade, the laptop (Win XP) stopped printing.  I have installed XP drivers for the printer (using the additional drivers feature) on Win 7, removed the printer connection from the XP machine and added it again.  The XP machine was able to find the printer on the network but when I try to print, I get an arror message saying that "the printer may be turned off, not connected or the drivers are not installed).

I think the two problems are related but I can't figure out where the problem is.  File printing and sharing is "on" in both machines, the firewall is set to allow file printing and sharing, the folders are set to "share", with "everyone" under permissions and the two machines have the same network name.

Any ideas? Am I missing something?  Is there any way to reset all values to default so I can setup the network again from scratch?

Thanks a bunch in advance.
|
Answer
Answer
You probably have a misconfigured firewall and/or don't have matching user accounts/passwords on both machines.
Here are general network troubleshooting steps. Not everything may be applicable to your situation, so just take the bits that are. It may look daunting, but if you follow the steps at the links and suggestions below systematically and calmly, you will have no difficulty in setting up your sharing.

Problems sharing files between computers on a network are generally caused by 1) a misconfigured firewall or overlooked firewall (including a stateful firewall in a VPN); or 2) inadvertently running two firewalls such as the built-in Windows Firewall and a third-party firewall; and/or 3) not having identical user accounts and passwords on all Workgroup machines; 4) trying to create shares where the operating system does not permit it.

In Windows 7, go to Control Panel>All Control Panel Items>Network and Sharing Center. Click on "Change advanced sharing settings". You don't want to use Homegroup unless you have all Windows 7 machines. If you do and you want to use Homegroup, see Windows 7's Help & Support. Otherwise, in the Advanced Sharing:

Turn ON network discovery
Turn ON file and printer sharing
Turn ON sharing in the Public folder sharing section
Turn ON password protected sharing

A. Configure firewalls on all machines to allow the Local Area Network (LAN) traffic as trusted. With Windows Firewall, turning on Window's File and Printer Sharing as above will take care of this for you. If you aren't running a third-party firewall or have an antivirus/security program with its own firewall component, then you're fine.  With third-party firewalls, I usually configure the LAN allowance with an IP range. Ex. would be 192.168.1.0-192.168.1.254. Obviously you would substitute your correct subnet. Refer to any third party security program's Help or user forums for how to properly configure its firewall. Do not run more than one firewall. DO NOT TURN OFF FIREWALLS; CONFIGURE THEM CORRECTLY.

B. For ease of organization, put all computers in the same Workgroup. This is done from the System applet in Control Panel, Computer Name tab.

C. Create matching user accounts and passwords on all machines. You do not need to be logged into the same account on all machines and the passwords assigned to each user account can be different; the accounts/passwords just need to exist and match on all machines. DO NOT NEGLECT TO CREATE PASSWORDS, EVEN IF ONLY SIMPLE ONES . If you wish a machine to boot directly to the Desktop (into one particular user's account) for convenience, you can do this:

Start>Search box>type: netplwiz [enter]
Click on Continue (or supply an administrator's password) when prompted by UAC

Uncheck the option "Users must enter a user name and password to use this computer". Select a user account to automatically log on by clicking on the desired account to highlight it and then hit OK. Enter the correct password for that user account (if there is one) when prompted. Leave it blank if there is no password (null).

XP - Configure Windows to Automatically Login (MVP Ramesh) - http://windowsxp.mvps.org/Autologon.htm

D. If one or more of the computers on your network is XP Pro or Media Center, turn off Simple File Sharing (Folder Options>View tab).

E. Create shares as desired. In Windows 7 I usually share out the user's Desktop and the Public directory.

F. After you have file sharing working (and have tested this by exchanging a file between all machines), if you want to share a printer connected locally to one of your computers, share it out from that machine. Then go to the printer mftr.'s website and download the latest drivers for the correct operating system(s). Install them on the target machine(s). The printer should be seen during the installation routine. If it is not, install the drivers and then use the Add Printer Wizard. In some instances, certain printers need to be installed as Local printers but that is outside of this response.

MS-MVP - Elephant Boy Computers - Don't Panic!
Elephant Boy Computers - Don't Panic!

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated January 9, 2020 Views 9,541 Applies to: