Netwoking Windows 7 with an Imac

I am having real problems trying to network my 4 computers.  2 Windows t and 2 Apples, iMac and MacBook.  Windows computer see othe Windows computer and the 2 apples see each other but Windows computers can't see Macs and visa versa.  File sharing is enabled on all computer.  Firewalls are off.  Can't network the computers or map drives.  Seems to be unique to Windows 7.  Had no problem with XP.

Suggestions/help.
Answer
Answer
helloo

Use this steps in mac.

Joining a Microsoft Windows workgroup

To help your PCs that shared files appear in the "Shared" section of your Mac OS X Finder sidebar, and for your PC(s) to locate your Mac that is sharing folders using SMB protocol on the network, you should have your Mac join the appropriate Windows workgroup.

Check with your Windows administrator to learn which Windows Workgroup you need to join.  Default Windows workgroups are "MSHOME" and "WORKGROUP".

1.Open Network preferences, in System Preferences, and ensure that the padlock in the lower left is unlocked.  If locked, click on it and, when prompted, enter an administrator name and password.  Click OK to continue.
2.Type "Workgroup" in the System Preferences search field and press Return. (Or, click "Network", select an interface, then click "Advanced", then "WINS".)
3.Enter a name for your Mac in the "NetBIOS Name:" field.
4.Enter the appropriate Workgroup you want to join join in the "Workgroup:" field.
5.Click OK.
6.Click "Apply" to complete the process.  It might take a few minutes for the PC(s) to appear in the "Shared" section of your Finder sidebar, and for PCs to see the Mac in this workgroup.


Regards.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated August 8, 2018 Views 10,504 Applies to: