Mapped drives disappear after logoff or reboot.

I cannot get a mapped drive to stay mapped after a log off in Windows 7.  Whether I map the drive by right clicking My Computer or by command prompt (net use f: \\sharename /persistent: yes), after the user logs off or reboots, the drives disappear. 

This is only happening to the users on Windows 7.  We have no problems with the users on XP.  Anyone have any idea?  I've tried logging in with different usernames, disabling 3rd party client firewalls, disabling UAC, etc. 

 

Question Info


Last updated September 15, 2019 Views 225,528 Applies to:
Answer
Answer

Hi CSholmire,

Thank you for letting us know your concern.

I would suggest you the below methods. Try performing these and check for the issue after each method:

Method 1:

  1. Open a Command Prompt as the user that the drives are not being remembered. Do not use the "Run as Administrator". In this case we don't want to do that. At the Command Prompt type: net use <enter>
  2. Does it say something like this: C:\>net use. New connections will not be remembered.
  3. If it says they "will not be remembered", then you need to change that. Type: net use /p:yes

That will change the system setting for the user to make the drives remembered all the time and will be the default action.

If the above is not the case then map the drive through the Command Prompt and see if the mapping is remembered.

net use /p:yes

net use r: \\servername\sharename

You may change the drive letter R: above to any free letter you wish. However remember that if you use a letter that is too close to the beginning of the alphabet you may overlap with USB devices and then one or the other will be missing. You can replace the R: with * and it will start with the next free drive letter starting at the bottom of the alphabet. That should make the drive be remembered through log off and reboot.

Method 2:

The long-term fix is a registry edit that will make mapped drives visible in both standard and administrative sessions.

  1. Press Windows +R and type in : regedit
  2. In Regedit, navigate to HKLM//SOFTWARE//Microsoft//Windows //Current Version//Policies //System.
  3. Create a new REG_DWORD entry named "EnableLinkedConnections".
  4. Set its value to 1.
  5. Reboot after adding the registry entry and programs will be able to see mapped drives forever.

Note: This section, method, or task contains steps that tells you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base: 322756 (http://support.microsoft.com/kb/322756/ )

How to back up and restore the registry in Windows

Keep us posted if you face any issues on windows in future. We will be glad to help you.

110 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Hi hanlee888,

I would suggest you to follow these steps and check if the issue is resolved.

1.      Open Computer by clicking the Start button, and then clicking Computer.

2.      Click Map network drive.

 

3.      In the Drive list, click a drive letter.

You can choose any available letter.

4.      In the Folder box, type the path of the folder or computer, or click Browse to find the folder or computer.

To connect every time you log on to your computer, select the Reconnect at logon check box.

5.      Click Finish.

 

For further information, visit the below mentioned link:

http://windows.microsoft.com/en-US/windows7/Create-a-shortcut-to-map-a-network-drive

 

 

 Hope this information helped!

 Thanks and regards

 Fouzan – Microsoft support

 Visit our Microsoft Answers Feedback Forum 

 http://social.answers.microsoft.com/Forums/en-%20US/answersfeedback/threads and let 

 us know what you think.

72 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.