Internet connection sharing over Ad-Hoc Network between Windows 7 and XP PCs

Hi everyone. 

I'm not terribly experienced with networking so let me know if I leave out any info that might be relevant. 

I am running Windows 7 64bit and have set up an ad hoc network between this computer and another computer running XP. The XP computer says that it is connected to the network however it will not connect to the internet connection from the Windows 7 computer. 

What I have done so far:

  1. Set up a wireless ad hoc (WEP)
  2. Copied the network profile to a USB flashdrive
  3. Plugged in to XP computer 
  4. Connected to the network on the XP PC
  5. Shared my internet connection on the Windows 7 PC
As I said, both the XP and Win 7 pcs say that they are connected via the ad hoc network, but the XP can't connect to the internet.

Any help is much appreciated, thanks in advance

Derek
 

Question Info


Last updated March 13, 2018 Views 41,742 Applies to:
Answer
Answer

Hi Derek, 

Here’s a link which has a detailed description to setup adhoc network between the computers of both Windows XP and Windows 7:

Set up a computer-to-computer (ad hoc) network 

http://windows.microsoft.com/en-us/windows7/Set-up-a-computer-to-computer-ad-hoc-network 

Set up a wireless network without a router

http://www.microsoft.com/windowsxp/using/networking/setup/adhoc.mspx 

Try setting up the Internet Connection Sharing(ICS) on the host computer(the computer whose Internet connection you plan to share):

1. Open Network Connections by clicking the Start button, and then clicking Control Panel. In the search box, type adapter, and then, under Network and Sharing Center, click View network connections.

2. Right-click the connection that you want to share, and then click Properties.  If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

3. Click the Sharing tab, and then select the Allow other network users to connect through this computer’s Internet connection check box.

Note:
The Sharing tab won't be available if you have only one network connection.

After you've followed the steps above to set up ICS on the host computer, make the following changes on all of the other computers (but not on the host computer).

1. Open Internet Options by clicking the Start button, clicking Control Panel, clicking Network and Internet, and then clicking Internet Options.

2. Click the Connections tab, and then click Never dial a connection.

3. Click LAN Settings.

4. In the Local Area Network (LAN) Settings dialog box, Under Automatic configuration, clear the Automatically detect settings and Use automatic configuration script check boxes.

5. Under Proxy server, clear the Use a proxy server for your LAN check box, and then click OK.

Refer these links for more idea on Internet Connection Sharing between computers connected on a adhoc netork:

Set up a shared Internet connection using ICS (Internet Connection Sharing) 

http://windows.microsoft.com/en-us/windows7/Set-up-a-shared-Internet-connection-using-ICS-Internet-Connection-Sharing 

Change Internet settings for ICS (Internet Connection Sharing) 

http://windows.microsoft.com/en-us/windows7/Change-Internet-settings-for-ICS-Internet-Connection-Sharing 

Additional information on:

Using ICS (Internet Connection Sharing)

http://windows.microsoft.com/en-us/windows7/Using-ICS-Internet-Connection-Sharing
 

Regards,

Divya R – Microsoft Support.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.