Homegroup created but not visible by other computers

Ok trying to connect desktop and laptop on homegroup network.  Both computers are going through the same router.  Both computer's time is in sync and the there is internet connection on both.  Both computers are in the same work group.  Both computers are running Windows 7 Home Premium.  

I created a homegroup with my desktop just fine, but the laptop will not see it.  I then created a homegroup with my laptop with no problems, but the desktop will not see it.  I have double checked everything on both computers and gone the unhelpful troubleshooters.  

The only difference I see between both computers is the name of the network they are connected to.  The laptop says it is connected to "oliver router" which is the name i setup on my router.  My desktop however says it is connected to "Network 3"...IT IS CONNECTED TO SAME ROUTER. Why would it have a different name??  If this is what is causing the problem I have been unable to find out how to change that.  

I beg for any help 


Question Info

Last updated October 14, 2018 Views 33,325 Applies to:

Hi oliverofthenight,

Network discovery might  be blocking you from seeing other computers and devices on the network. Check if the Network discovery if turned on. If the network discovery setting on your computer is set to Off, you won't see other computers and devices on the network.


 To change your network discovery setting, follow these steps:

1.      Open Advanced sharing settings by clicking the Start button, and then clicking Control Panel. In the search box, type network, click Network and Sharing Center, and then, in the left pane, click Change advanced sharing settings.

2.      Click the chevron to expand the current network profile.

3.      Click Turn on network discovery, and then click Save changes. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.


For further information, visit the below mentioned link:



You may also refer the below mentioned links.





Hope this information helped!

 Thanks and regards,

 Fouzan – Microsoft support.

 Visit our Microsoft Answers Feedback Forum 

 http://social.answers.microsoft.com/Forums/en-%20US/answersfeedback/threads and let 

 us know what you think.

16 people were helped by this reply


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.