Question

Q: Home network filesharing - Access denied!

I've been trying to figure this out for a week now. No matter what I try I cant seem to copy/move/delete files from one of the pcs on my home network although I can browse to it. I get the dialog box:

File Access Denied
You need permission to perform this action.

I'm using windows 7 on 2 home pcs and 1 laptop. I had filesharing working flawlessly on the network before I upgraded one of my pcs and now that is the only inaccessible one. My settings:

All PCs on HOME homegroup with same homegroup password
file and print sharing is on
password protected sharing is off
Trying to share C:\Downloads
Permissions for 'everyone' set to full control.
Firewall disabled

Ive tried taking ownership/auditing and adding 'full control' to the groups 'Everyone', 'Authenticated Users' and 'Administrators'
I've tried uninstalling my firewall
I've tried reinstalling the lan driver with the latest one from the motherboard website
I've tried a clean install of windows 7 and still no luck.
homegroup diagnostic finds nothing wrong.

Any help appreciated!

Answer

A:

Hi,
I would suggest you to try the steps mentioned below.
 
Method 1:
Use “Shared Folders troubleshooter” in Windows 7
a.    Open the Shared Folders troubleshooter by clicking the Start button, and then clicking Control Panel.
b.    In the search box, type troubleshooter, and then click Troubleshooting.
c.    Under Network and Internet, click Access shared files and folders on other computers.
Refer the following link.
Open networking troubleshooters
http://windows.microsoft.com/en-us/windows7/Open-networking-troubleshooters

Method 2:
Use Advanced sharing option in Windows 7
a.    Right-click a drive or folder, click Share with, and then click ‘Advanced sharing’.
b.    In the dialog box that appears, click Advanced Sharing. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.
c.    In the Advanced Sharing dialog box, select the Share this folder check box.
d.    To specify users or change permissions, click Permissions.
e.    Click Add or Remove to add or remove users or groups.
f.     Select each user or group, select the check boxes for the permissions you want to assign for that user or group, and then click OK.
g.    When you've finished, click OK.
 
Additional information:
 
Share files with someone
http://windows.microsoft.com/en-US/windows7/Share-files-with-someone
 

Hope this information is helpful and let me know if you need any further assistance.
Thanks,
Yaqub Khan

Did this solve your problem?

Sorry this didn't help.



 
Question Info

Views: 1,517 Last updated: June 18, 2018 Applies to: