FTP server error: "The folder you entered does not appear to be valid. Please choose another."

Original title: Odd error when trying to map FTP server to a network drive

OS: Windows 7: Home Premium x64

Hello. I've been trying to map an ftp server in which I can successfully access with a web browser. However Windows will not let me map it to a drive.

Steps I've done to attempt to map drive:
1. Right click Computer
2. Click Map Network Drive
3. Click "Connect to a Web site that you can use to store your documents and pictures."
4. Go through Add Network Location wizard
5. Upon entry of ftp address, the following error is displayed: "The folder you entered does not appear to be valid. Please choose another."

Upon receiving this error, I ran the following Trouble Shooter in Windows' Action Center: Control Panel > All Control Panel Items > Troubleshooting > Network and Internet > Shared Folders

I run the troubleshooter and provide the ftp - "\\IP ADDRESS\"

The following is displayed: "The remote device or resource won't accept the connection"

I clicked "View Detailed Information"

Under Issues Found: "The remote device or resource won't accept the connection.  The device or resource (IP ADDRESS) is not set up to accept connections on port "The File and printer sharing (SMB)".

 

Question Info


Last updated May 22, 2019 Views 26,961 Applies to:
Answer
Answer
I found a fix on this website: http://social.technet.microsoft.com/Forums/en/ieitprocurrentver/thread/3d74bc03-b0c4-4ec1-88df-b938ec82c159

Many thanks to TerkildHolst who had the solution for Windows 7!  It seems that Google Chrome causes this problem.  To fix, copy the following bold text.  Save it to a text file.  Change the text file name to ftp.reg.  Double click the file and voila!


Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\ftp]
@="URL:File Transfer Protocol"
"AppUserModelID"="Microsoft.InternetExplorer.Default"
"EditFlags"=dword:00000002
"FriendlyTypeName"="@C:\\Windows\\system32\\ieframe.dll,-905"
"ShellFolder"="{63da6ec0-2e98-11cf-8d82-444553540000}"
"Source Filter"="{E436EBB6-524F-11CE-9F53-0020AF0BA770}"
"URL Protocol"=""

[HKEY_CLASSES_ROOT\ftp\DefaultIcon]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
  00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,75,00,72,00,\
  6c,00,2e,00,64,00,6c,00,6c,00,2c,00,30,00,00,00

[HKEY_CLASSES_ROOT\ftp\shell]
@="open"

[HKEY_CLASSES_ROOT\ftp\shell\open]

78 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Hi,

I would suggest you to follow these steps and check if it helps.

 

a)      Open Windows Explorer and choose the “Map Network Drive” option.

Windows 7 location: Along the top toolbar

b)      Choose the option at the bottom that reads:

Windows 7 location: “Connect to a Web site that you can use to store your documents and pictures”

c)       Click “Choose a custom network location”:

d)      Enter in the FTP address for the site:

e)      Enter the username for the FTP server (you will be prompted for the password when you connect).

f)       Enter a name.

g)      Finish up the wizard, and then you’ll be ready to connect! You’ll be prompted for the password the first time that you try and connect, but you can have the password saved after that if you wish.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.