Event ID 1002 DHCP error - Unable to connect to the internet

When I switch on my modem very frequently it does not get connected to the internet. The event log shows me a DHCP client error "The IP address lease 192.168.1.2 for the Network Card with network address 0x3860772E**** has been denied by the DHCP server 192.168.1.1 (The DHCP Server sent a DHCPNACK message)". I have searched a lot of methods to resolve this but nothing seems to work, I used microsoft fix it to disable ipv6. I have tried manually entering the ip4 properties and even tried the automatic ip address determination but still the same problem. I have even tried typing ipconfig /release in the cmd window but it gives me an error "no adapter is in the state permissible for this operation" at this point I am also unable to connect to the modem @ http://192.168.1.1(firefox gives me an error) . The only fix I seem to find is to constantly keep changing the ipv4 IP address(manual configuration of ipv4 properties) every time the problem occurs. For example if I have set the IP address to be 192.168.1.2  and I change it to 192.168.1.3 it instantly gets connected.
 

Question Info


Last updated September 7, 2019 Views 10,667 Applies to:

Hi,

Have you made any changes to the computer prior to this issue?

 

I would suggest you to try the following methods and check if it helps.

Method 1:

Run the network troubleshooter and check if it helps.

Open networking troubleshooters:

http://windows.microsoft.com/en-US/windows7/Open-networking-troubleshooters

 

Method 2:

Check for the service DHCP Client and DNS Client Services if they are started or not.

 

a.       Click on Start, type Services.msc in the search box and press Enter.

b.      Locate the services: DHCP client and DNS client.

c.       Check if the below mentioned services has the mentioned status and start up type.
DHCP Client   Started      Automatic\Manual.
DNS Client      Started      Automatic\Manual.

 

And also check the dependency services that are required for DHCP Client and DNS Client Service to run.

To check that double click on the service and click on the dependency tab.

 

Method 3:

Try to update the Network adapter drivers and check if it helps.

Update a driver for hardware that isn't working properly:
http://windows.microsoft.com/en-us/windows7/Update-a-driver-for-hardware-that-isnt-working-properly

 

Method 4:

Try to uninstall and reinstall the network adapter.

To uninstall drivers follow the steps given below.

 

a.       Click StartCollapse this imageExpand this image, type Device Manager in the Start Search box, and then press ENTER.

b.      Click Continue. The Device Manager Dialog box is displayed.
Collapse this imageExpand this imageIf you are prompted for an administrator password or for a confirmation, type the password, or click Continue.

c.       In the list of device types, click the kind of device, and then locate the specific device that is not functioning.

d.      Right-click the device and then click Properties.

e.      Click the Driver tab.

f.        Click Uninstall.

g.       Click OK.

Restart the computer, the default drivers would be installed.

 

Hope the information is helpful.

Basith M
- Forum Moderator (Multiple Forums)

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Found the problem eset firewall was blocking the connection after I disabled it and enabled windows firewall, it starts blocking the router ip (i.e 192.168.1.1). When I disable windows firewall internet connects instantly. How can I resolve this without disabling windows firewall ?

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.