Question
361226 views

error 651 in windows 7

Ratty2103 asked on
Hi,
I just purchased a new desktop and installed Windows 7 Profesional.
I was able to connect to the internet via the router, after a lot of messing about and was able to register, activate and update my installation. However, today, when I booted the destop, it wouldn't connct to the internet, or see the othe computers or printer in my home network. Whenever I try to connect, I receive the following :-error 651  and when I run Network Diagnostics, it returns with ""Local Area Connection" does'nt have a valid IP Configuration."
I have swapped the cables between computers and the problem stays with the new box. My laptop wirelessy connects via the router and sees the other devices ok.
Having checked on the intereet, I see that this is a common problem with Win 7 and have already tried the "raspppoe.sys " as suggested by "Shinmila H-Microsoft supprt on social.answers.microsoft.com. to no avail.
Please advise, or Email a hotfix.
Thanks for your attention in this matter.
Callum
491 people had this question

Abuse history


The answered status icon Answer
Nithyananda J replied on

Hi,
 
Could you please answer these below questions?
 
1. Did you follow all the steps which Shinmila H suggested you to do?
 
2. Are you using Dial-up or Broadband connection?

First I suggest you to reset tcp/ip on your computer, to do that you may visit the below link.

How to reset Internet Protocol (TCP/IP)

http://support.microsoft.com/kb/299357

Change TCP/IP settings

http://windows.microsoft.com/en-US/windows7/Change-TCP-IP-settings
 
I suggest you to Power cycling your Modem and Router might resolve the problem, here are the steps:

 
1.Save all your current work, close all open applications, then shut down your computer. Wait for a minute.
2.First, turn your Router off and wait for a couple of minutes.
3.Turn off your modem.
4.Disconnect all the Ethernet cables that are connected to the router and modem and the PC.
5.Reconnect them and ensure that there are no loose connections in between them.
6.Now, switch on your PC and let it boot.
7.Switch on the modem first and after it gets initialized, switch on the router.
 
You can also try disabling Firewall/Security Software if any, and check if it helps:

http://windows.microsoft.com/en-US/windows7/Disable-antivirus-software
 
I also suggest you to refer this link which talks about the same issue:

http://social.answers.microsoft.com/Forums/en-US/w7hardware/thread/af815085-fc76-458a-8116-98a06be817ea/

Ensure that you enable the Security program on your computer.

Thanks and Regards:
I. Suuresh Kumar- Microsoft Support.
Visit our Microsoft Answers Feedback Forum and let us know what you think.

30 people found this helpful

Abuse history


Most Helpful Reply
HVerma replied on

A very simple way to solve the problem was to go to control panel following location
Control Panel\Network and Internet\Network Connections
Right click on broadband connections [WAN Miniport(PPPOE)] and un-check set as default.
59 people found this helpful

Abuse history


progress