Drivers for NETGEAR WG311v3 54 Mbps Wireless PCI Adapter are not working.

 Windows 7 installs the drivers for the WG311v3 automatically, but after the install, the hardware isn't working and I have an exclamation point next to the wireless card in the device manager.  I then looked at the properties and saw in device status that "The device cannot start. (Code 10)"  This device worked on vista, but is not working on 7. I have installed the drivers that came with it and tried all the compatiblity modes, but nothing works. Any Suggestions?

My hardware is
- Intel Core 2 Quad CPU Q6600 @ 2.40Ghz
- 4 GB DDR2 800
- Geforce 9600 gt
- mobo: Asus PN5D

 

Question Info


Last updated October 18, 2018 Views 43,433 Applies to:
Answer
Have a look here

http://kb.netgear.com/app/answers/detail/a_id/11127/kw/Windows%207/r_id/100109

above driver link


http://forum1.netgear.com/showthread.php?t=41978

I haven't updated my but did some research on the whole thing.


19 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.