Question

Q: Disconnected network drive error as follows: "An error occurred while reconnnecting X: to \\CompanyServer\ShareFolder\users\jones Microsoft Windows Network: The local device name is already in use. This connection has not been restored."

"An error occurred while reconnnecting X: to \\CompanyServer\ShareFolder\users\jones Microsoft Windows Network: The local device name is already in use.  This connection has not been restored.

This is the exact error I get, on a Windows 7 client workstation, operating in a domain environment with Windows Server 2003 domain controllers.  Reconnection of assigned user drives is scripted, and is run on upon logging in.  Windows XP client computers do not have this problem.  Since the scripted-in-group-policy drives disconnect after a short while, I've created mapped drives to solved the problem.  No good; they all still disconnect after a short while and the user gets a red X over the network drive.

What is causing this error and dis

Answer

A:

I was having this issue on Win 7 and solved it with this:

http://support.microsoft.com/kb/297684#LetMeFixItMyselfAlways

I did the registry change "by hand" instead of the auto-fix, but that probably does not matter.  Have had no further issues. 

Did this solve your problem?

Sorry this didn't help.

79 people were helped by this reply

Answer

A:

Either the local drive letter is used by a USB mass storage device or else it is remembered from a previous session. Run the following commands just once to fix the problem:
net use * /del /yes
net use /persistent:no

Did this solve your problem?

Sorry this didn't help.

296 people were helped by this reply



 
Question Info

Views: 131,760 Last updated: June 18, 2018 Applies to: