Windows 7 support has ended

Get Windows 10 to continue receiving support.

Upgrade now

diagnostic policy service not running - windows 7

Hi I run windows 7 on my HP laptop but unable to get on the internet. When i use the troubleshoot option it comes up as an error saying diagnostic policy service is not running. Can n e one help with this issue. I have tried a number of solutions on the internet but to no avail. thanks
Answer
Answer
Hi


Assuming that the Router's Wireless is configured correctly that there is a strong signal and the Wireless card on the Computer is physically on.

Maybe this can Help.

Go over these steps and tell us where the breaking point is.

Check the Device Manager for valid Wireless card entry.

http://www.ezlan.net/Win7/net_dm.jpg

If there is No valid entry, delete any Bogus Entry, and re-install the Wireless card's Drivers.

Check the Network connections to make sure that you have a Wireless Network Connection Icon/Entry, and that the Properties of the Icon (right click on the Icon) are correctly configured with TCP/IPv4 protocol in the Network Connections Properties.

http://www.ezlan.net/Win7/net_connection_tcp.jpg


------------------

Many Wireless cards' drivers also install the vendor's Wireless utility.

Make sure that if there is a vendor's Wireless Utility is Not Running together with the Windows native Wireless utility (WLAN Service) .

----------------

Make sure that No Firewall is preventing/blocking the Wireless components to get to the Network.

Some 3rd party Software Firewalls/AV/Security suit,s keep blocking aspects of Local Traffic even it they are turned Off (disabled).

If possible configure the Firewall /Security suit correctly, otherwise totally uninstall it, and get rid of its residual processes to allow clean flow of local network traffic.

If the 3rd party software is uninstalled or disables, make sure that Windows native Firewall is On .

3rd party Network mangers like Bonjour, and NetMagic can block local traffic too.

---------------------------

Working TCP/IP stack should look this way.

Right click on the Wire card Network Connection, choose Status, Details, and see if it got an IP and the rest of the settings.

http://www.ezlan.net/Win7/status-nic.jpg

Description is the card manufacturing data.

Physical address is the card's MAC number.

The xx should be a number from 0 to 255 (all xx same number).

yy should be from 0 to 255

zz should be from 0 to 255 (all zz the same number.

The lease date should be valid to the current time.

*Note 1. IP that starts with 169.xxx.xxx.xxx is not valid functional IP.

*Note 2. There might be an IPv6 entries too. However, they are not functional for Internet traffic or LAN. They are needed for Win 7 special HomeGroup configuration.

---------------------------------------------------

A message in the Wireless little Window that says Connected does not means that your are really have a valid functional connection.

If everything above is OK you have to be able to connect to the Router.

Connecting to the Router means that you can enter the Router's core IP into an address bar of a browse, be able to connect, see, and configure the Router's menus.

If it does not connecting to the Router, log from any computer that can connect to Wireless Router with a Wire, disable the Wireless Security, make sure that the Wireless broadcast SSID is On,  and try to connect with No Wireless security.

Enable the Wireless security after you mange to establish a functional connection.


Jack MVP, Microsoft Windows Desktop Experience-Networking.

www.EZLAN.net

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated August 27, 2018 Views 10,400 Applies to: