Can't "turn on Network Discovery" in Homegroup conection, keeps reverting back to "off"

Trying to set up Homegroup on Desktop and Laptop but when I try to "turn on Network Discovery" it always reverts to "off"

-

both are using Windows 7 Professional 32 with AVG

 

Question Info


Last updated September 25, 2018 Views 6,355 Applies to:
Answer
Answer

Hi,

1.       What kind of connection are you using (Wireless or Wired)

2.       Did you make any changes prior to the issue?

3.       What network location type have to chosen? Is it Home, Work or Public?

Based on the network location you choose, Windows assigns a network discovery state to the network and opens the appropriate Windows Firewall ports for that state.

Step 1: We recommend you to check if the network discovery items are enabled in Windows Firewall. To do this, try these steps.
1. Click Start, type firewall and click on Windows Firewall with advanced security.
2. Click inbound rules in the left pane and enable Network Discovery (SSDP-In) and Network Discovery (UPnP-In) from the list.
3. Click Outbound rules in the left pane and enable Network Discovery (SSDP-Out) and Network Discovery (UPnP-Out) from the list.
4. Apply the changes and check the result.
 
For more information on network discovery, check this link:
http://windows.microsoft.com/en-us/windows7/What-is-network-discovery

Step 2: Check for the status of the following services: Computer Browser, TCP/IP NetBios Helper.
1. Click Start, type services.msc and hit enter.
2. From the list of services, double click on Computer Browser and TCP/IP NetBios Helper service.
3. Change the startup type to automatic and start the services.
4. Apply the changes.
 
Try the steps and post back the results, so that we can assist you further.

 

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.