Question
32388 views

Cannot "Turn on media streaming" - another Windows 7 user with the same problem, and 'suggested fixes' not working.

rustyd asked on

This windows bug has been reported and 'answered' before by several people, but the 'answers' do not work for me - nor do they seem to work for many other people in this and other forums.  I hope you can provide me with a real diagnosis, a reason for why this happens, and a real solution that works for everyone.

I am trying to 'Turn on media streaming' in Windows Media Player so I can stream to my xbox and other home theatre equipment.  The problem I have is the same problem that [many] other people have reported: in Windows Media Player, I press the Turn on media streamin 'link', the button greys shortly, but then nothing, and streaming is not enabled.

I do not have a network problem.  I was able to extend Microsoft Media Center to my xbox.  (just not turn on streaming in WMP).  Using media center extended is a great (better) workaround for the xbox, but it is not a solution for my other home theatre devices. I need to be able to stream to my receiver and blu-ray player as I was able to do on my old PC running Windows XP. 

I have a new install of Windows 7 Pro, x-64 on a new self-built machine.  Everything else works, its not the machine.  I have installed all the latest drivers for my machine.  I have all the latest updates for Windows 7.  I run Windows Firewall and Kaspersky Anti Virus 2010.  I have installed Microsoft Office 2007, Outlook 2007, Visio 2010, and many other 'standard' applications.  I am not running any 'weird' low-level programs.

As other people 'suggested' I have already tried the action of exiting WMP, stopping the Windows Media Player Network Sharing Service using service.msc, then removing the .wmdb (and other files but not directories) from my Users/xxx/AppData/Local/Microsoft/Media Player dirctory, restarting the WMP Network Sharing Service using services.msc, and then restarting WMP.  This had no effect.  (I tried this several times with and without restarting the WMP Network Sharing Services manually.  I tried changing the Windows Media Player Network Sharing Service, Log On tab from Network Service (the default on my system) to Local System with 'allow services to interact with desktop' selected as someone else 'suggested'.  This didn't seem to effect anything.  I also tried uninstalling WMP and WMC  Player (using 'Turn Windows features on or off'), restarting, then adding them back and restarting.  This time at lesat the 'Turn media sharing on' icon came back in WMP  (the icon is usually gone from the WMP Stream/Turn on media sharing window).  This time Windows 7 Pro thought about it a little longer before doing nothing.  (However, now I get an error message 'An error has occurred. Not all of the features were successfully changed.' when attempting to 'reinstall' Windows Media Center after reinstalling WMP.)  The reinstall of WMC didnot return an error.  I can no longer start Windows Media Center on my PC.

So, by all the messages on this topic, its obvious this is a real bug in Windows 7 (maybe only on Pro?), (maybe only on x-64?).

Just two more things about my setup... I did not originally set up homegroup (because I have no other Windows 7 machines), but I did try setting that up to see if it had an effect (it didn't).  The only 'weird' part of my install, is that I mounted my D: drive (2nd harddrive) on C:\Users (because I use a Solid State Drive for the OS on C: and dont want the Users data on it).  This has not caused any other problems, but I wanted to throw it out there in case Windows Media Player sharing does something weird here.  (And no, I'm not going to 'try changing' that, unless its a known fact that this is the problem - and then I would need a different solution for moving my Users data off the SSD.)

So please, let me know what the real problem is, why it happend to me (I'm sure some people can turn streaming on in WMP), and what the real solution is.  (There seem to be a multitude of suggestions on the web for all kinds of different 'fixes', but which, if any, is the right one?  Please do not just suggest things to try.  What's the right fix?

30 people had this question

Abuse history


The answered status icon Answer
xI GifteD replied on

Go to network and sharing center open view full map, right click on your PC and click manage.

then open services and applications, then serivces and find Upnp device host, right click and click restart,and make sure it is set to Automatic.

Now scroll down to Windows Media Player Network Sharing service, right click and click restart, and make sure this is set to Automatic also.

That should work, it worked for me and everyone i know but... The only problem i have is when i restart my PC the Windows Media Player Network Sharing service changes from automatic to automatic (delayed start) and i have to Restart the Upnp device host and the Windows Media Player Network Sharing service again.

Other than having to do this every time i restart my PC it works perfect. 

Also, if anyone has any idea to why it changes to (delayed start) let me know thanks..

17 people found this helpful

Abuse history


The answered status icon Answer
TK Takaishi replied on

ok if your still needing help i may be able to give you a solution.

IF your trying to share on windows 7 with your xbox/ps3

on your computer

1. go to windows media player

2. makes sure your switched to library

3. click on stream

4. now click on the bottom one which should say allow windows media sharing or something like it.

it will now prompt you to allow devices next click ok. and it should work. have any questions just e-mail me*** Email address is removed for privacy ***

7 people found this helpful

Abuse history


progress