Cannot delete homegroup network share

Ok, so this is a bit of an interesting one!

I setup a homegroup between 2 computers, a media center machine and a laptop.

On the media center machine I shared a number of folders.  These folders were shared in a couple of different ways.  Some just by enabling sharing (right-click, properties, advanced sharing, share this folder), but one was shared by selecting share with homegroup (read). 

All was good (if messy!)!  But then I decided that with an upgrade to the machine I would sort out all the sharing and do it properly by adding the folders to libraries and sharing the libraries.  During the upgrade I installed a new hard drive and I changed the drive letter for the drive where all the shares were located (the beginning of the problem).

None of the shares now work (although they do appear on the laptop, and in the network section of explorer on the media center).  Unfortunately, I found I coudn't remove the shares!  Right-clicking on a share in the network area of explorer (on the media center), properties, advanced sharing and disabling the share results in an error dialogue when you click OK because windows cannot find it!  The only way I got round this was to recreate dummy folders with the same names as before so that windows can 'find them' and then remove the share.  This problem was compounded by the fact that you cannot 'see' where the share actually points to.

Anyway, after a bit of work this sorted out all the shares apart from the HomeGroup one.  Because this only exists in the homegroup section of explorer (for some reason not in the network area of explorer - I don't know why) I can't right-click and unshare it.  If I create a new folder with the same name in the old location and share it, this creates an additinal share, and BOTH list the contents of this folder!  But if I then unshare it, only the newly created share disappears.

I'm assuming that windows must keep a list of the homegroup shares somewhere.  I've searched the registry with the name of the folder but I haven't found anything (I think - it has references but I think these are search indexes).  If anyone could give me an idea of what to do next or where to look I'd really appreciate it (i've been at this for a few days now!).   

sShnoop

|
Answer
Answer

This shouldn't be too hard. Try this:
1. Boot into Safe Mode with Networking.
2. Log on as Administrator.
3. Click Start.
4. Type the three letters cmd into the Search box.
5. Press Ctrl+Shift+Enter
6. Click "Run as Administrator".
7. Type the following commands:
    net share
    This command shows you the names of all shares you created.
    net share "users" /d
    This command deletes the "Users" share (which got created automatically by the Homegroup)
    Continue like this until you have deleted all unwanted shares.
_________________________

If this response resolves your problem, please click "Propose as answer" so that the thread can be closed. Thanks.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated November 6, 2018 Views 13,417 Applies to: