I am getting an error "Access is denied" when trying to access a shared drive on windows 7 machine that is not the specified "public" folder. how do i fix this?. i have done a fair bit of googling to no avail! help.

I am getting an error "Access is denied" when trying to access a shared drive on windows 7 machine that is not the specified "public" folder. how do i fix this?. i have done a fair bit of googling to no avail! help.
I have also made all he necessary network and sharing settings to allow connections. Other computers can access the "public" folder... but not the other shares that i set up... although the other computer/s can 'see' them when viewing workgroup computers.
NB. All machines are on the same workgroup name.
 
Question Info

Last updated March 13, 2018 Views 1,497 Applies to:
Answer
Create identical user accounts/passwords on all the machines. Make sure your share permissions give "Everyone" full control.

In Windows 7, go to Control Panel>All Control Panel Items>Network and Sharing Center. Click on "Change advanced sharing settings". In the Advanced Sharing:

Turn ON network discovery
Turn ON file and printer sharing
Turn ON sharing in the Public folder sharing section
Turn ON password protected sharing


If one or more of the computers on your network is XP Pro or Media Center, turn off Simple File Sharing (Folder Options>View tab).
MS-MVP - Elephant Boy Computers - Don't Panic!
Elephant Boy Computers - Don't Panic!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.