Windows can't open Add Printer. Operation could not be completed error 0x000006be

Original title: Spooling issue and others with printer

 

I have a printer issue. Printer was previously installed and worked fine for months. One day it just stopped working.
I could see it the 'device and printers' but icon was with some numerical description. At the same time, no printing action was possible from any programs such as word, firefox, explorer etc.
I tried to add printer but I got error "Windows can't open Add Printer. The local print spooler service is not running. Please restart the spooler or restart the machine." After I got to services and started spooler I had another error: Windows can't open Add Printer. OPeratin could not be completed )error 0x000006be)
After a while, spooler stops by itself anyway. I tried t change to manual and than back to automatic, but it did not prevent from being stopped again.
I installed printers manufacturer software, and it did not help either. I do not see printer in any programs such as word.
Same printer works with not problems from other computer with same Windows 7 64 bit. Both connected to the printer via wireless router.

Thanks for any help

Daniel

 

 

Question Info


Last updated December 12, 2018 Views 7,946 Applies to:

Hi,

 

Thank you for posting the question on Microsoft community forums. It looks like printer stopped working and getting an error message “Windows cannot connect to the printer. Operation could not be completed (error 0x000006be)”. Let’s perform few steps and try to resolve the issue.

 

 

Please answer few questions to narrow down the issue.

 

1.       What is the make and model of the Printer?

2.       Are you aware of making any changes to the computer prior to the issue?

3.       Have you installed the appropriate driver for the device from the printer manufacturer website?

 

 

Method 1:

 

 

Update the driver for the printer and run the troubleshooter.

Fix printer problems

http://windows.microsoft.com/en-US/windows/printer-problems-in-windows-help#fix-printer-problems=windows-7&v1h=win8tab1&v2h=win7tab1&v3h=winvistatab1&v4h=winxptab1

 

 

Method 2:


Clear Printer Spooler files and enable the spooler service


a. Click Start, click Run, type "Services.msc" (without the quotation marks) in the open box and click OK.
b. Double-click "Printer Spooler" in the Services list.
c. Click Stop and click OK.
d. Click Start, click Run, type "%WINDIR%\system32\spool\printers" in the open window, and delete all files in this folder.
e. Click Start, click Run, type "Services.msc" (without the quotation marks) in the open box and click OK.
f. Double-click "Printer Spooler" in the Services list.
g. Click on Start. In the Startup Type list, make sure that "Automatic" is selected and click OK.

 

 

You can refer the below article in which another user had same issue. You can try the different potential steps stated in the thread:

http://social.technet.microsoft.com/Forums/en-US/itprovistaprinting/thread/3e47b7b6-00a3-47e1-9e28-e615fbff5f87

 

Note:

 

This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the windows help article below.

 

Back up the registry
http://windows.microsoft.com/en-us/windows7/Back-up-the-registry

 

 

Hope this information helps. Please reply with the status so that we could help you further.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Winston,

Thanks for help. Unfortunately here is what happened.
Method 1 did not work, windows could not start printer spooler.,
Method 2 did not work, printer spooler is stopped right from the system start.  After I go to services and start it, it stops again after short period of time. Changing to different options and back to "Automatic" does not help. If I start spooler manually and right away try to add printer, than it shows error 0x000006be. There is no file in the Printer folder.
Method 3 registry:
a) no additional items in "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environment\Windows NT x8"
b) no additional items in "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors registry key". But there are two components missing from the list:

BJ Language Monitor  - missing
Local Port
Microsoft Document Imaging Writer Monitor - missing
Microsoft Shared Fax Monitor
Standard TCP/IP Port
USB Monitor
WSD Port


To answer to your questions from the beginning of your post:
1. My printer is Brother MFC - 495cw.
2. I do not recall any major changes prior the problem. Additional wireless network (my office) was added recently, but I can not be 100% sure if the issue happened before or after.
3. I did installed proper driver - did not help. 
I installed original Brother software. There is an icon of printer with yellow triangle with exclamation sign. Still there is no printer in any other software like word.

After I remove the printer from "devices and printers" icon disappears. Function "add printer" does not work saying "spooler error"

I am able to add printer through "add device" command. But icon stays with yellow triangle and exclamation sign, and printer is not available in any software again.

Any other ideas on what might be wrong. I need the printer to be hooked up to my laptop as this is my work tool.
Thanks,

Daniel

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.