Windows 7 USB power management won't allow me to un-check the "Allow the computer to turn off device..." box

Hi all,

I'm having huge problems charging ipods and a blackberry via usb on my windows 7 (desktop) machine.  I will add that this is the same hardware that 2 weeks ago had windows xp and the usb charging worked fine on all devices from all ports--front and rear.

I go to device manager and uncheck the box "Allow the computer to turn off this device to save power" on all usb-hub entries, and while the checkbox becomes "unchecked", there is no change in charging ability but more curiously--when I restart the computer this box is checked again for all hubs.

How can I force this box to stay unchecked.  This is *not* a laptop.  I don't care if there's power at the device at all times.  It doesn't drain power when nothings connected so I don't see the issue here.

thanks,

--Jim

 

Question Info


Last updated October 8, 2018 Views 43,660 Applies to:
Answer

Hi James1109,

There is a workaround for this problem. Disable theUSB selective suspend option. To do this, follow these steps:

1. ClickStart, type power options in the Start Search box, and then clickPower Options in the Programs list. If you are prompted for an administrator
password or confirmation, type your password or click Continue.
2. Under the selected power plan, click Change plan settings.
3. Click Change advanced power settings.
4. In the Power Options dialog box, expand USB settings, and then expandUSB selective suspend setting.
6. If you want to disable Windows 7 to turn off the USB root hub click Disabled in thePlugged in list, and then click OK

If that doesn’t help, then I would suggest you to create a new power plan and check if it fixes the problem.

Refer these links for help:

Change, create, or delete a power plan (scheme):
http://windows.microsoft.com/en-us/windows7/Change-create-or-delete-a-power-plan-scheme

Power plans: frequently asked questions:
http://windows.microsoft.com/en-us/windows7/Power-plans-frequently-asked-questions



Regards,
Afzal-Microsoft Support.
Visit our Microsoft Answers Feedback Forum and let us know what you think.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.