Windows 7 not recognizing FAT32 formatted devices / Windows asks to format any USB device formatted with FAT32

I have a question concerning Windows not recognizing USB devices formatted in FAT32.

 

The biggest symptom is Windows asking to format any device that has FAT32 (the file format shows as RAW in Disk Management. The format will fail unless NTFS is used (which is unacceptable for SD cards used in cameras etc.)

I have a Toshiba Satellite P755 with one USB 3 port and three USB 2 ports running Windows 7 64bit. Apparently computer type and for the most part device type is irrelevant regarding this issue after doing some exhaustive research.

 

1. I have tried SFC / SCANNOW with no results

2. I uninstalled all USB drivers and SD card device drivers with no results

3. I created a new profile and moved my files over with no results

4. I searched the net and found a plethora of people with the same problem on multiple versions of Windows but no confirmed fix.

5. I tried the Microsoft hardware troubleshooter fix with no result.

 

The devices I used are pen drives, flash drives, multiple types of SD cards, and external hard drives. These devices are confirmed to work on several other computers in different windows configurations. When formatted to NTFS they all will work but as I stated before, the SD cards will not work in cameras etc. in the NTFS format.

 

I think wiping the computer and starting over isn't solving the problem. After conducting research, I discovered this problem has been around for many years and followed from Windows XP all the way through Windows 8 according to the forums and blogs I read. I'm surprised Microsoft doesn't have a fix for this yet.

 

Question Info


Last updated January 24, 2020 Views 30,389 Applies to:
Answer
Answer

Hello and sorry about the delay.

 

I tried this previously with the same results. My pen drives and SD card worked great until the problem occured. Windows 7 lost the ability to recognize FAT32 devices.

 

I think I found the problem though. My pen drive must have failed in some way. After confirming all my media were working properly on a spare desktop computer running windows 7 64, I popped in a sansa disk thumb drive and thats when I started to get errors on this computer as well. This time no data survived.

 

I went back to my laptop and formatted it with a new copy of windows professional 64bit. The laptop runs great and recognizes all the FAT32 media I throw at it. I am not using the suspect USB drive for fear it might cause the problems again.

 

And so far so good a couple of weeks later. Everything is running great. I've used many different FAT32 media with no problems. I am pretty sure it was the drive. I guess the fact that it worked intermittenly masked the fact that it was the cause of the problems. Strange that it would cause windows to reject FAT32.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.