Windows 7 - Bluetooth Adding Device Process Never Ends Up

I have just bought an HP Pavilion g6-2004tu Notebook PC. The bluetooth device as per the device manager is found to be working properly. However, when I try to add a device on bluetooth the process carries on without stopping or showing any device. The device manager also shows an unknown PCI device and finding any driver for or identify. Sure would oblige any of you experts' help.

Thanx in advance.

Running Win 7 Ultimate (64 Bit)

 

Question Info


Last updated February 28, 2018 Views 271 Applies to:

Hi,

1.       Were there any recent changes to the system prior to the issue?

2.       Do you get any error message when you try to add the Bluetooth Device?

Method 1:

Follow the link mentioned below, follow the steps to install a Bluetooth Device and check if it helps.

Add a Bluetooth enabled device to your computer

http://windows.microsoft.com/en-MY/windows7/Add-a-Bluetooth-enabled-device-to-your-computer

Method 2:

Follow the link mentioned below, update the drivers for the Bluetooth Generic Device adapters and check if it helps.

Update a driver for hardware that isn't working properly

http://windows.microsoft.com/is-IS/windows7/Update-a-driver-for-hardware-that-isnt-working-properly

For more information refer:

Change settings for a Bluetooth enabled device

http://windows.microsoft.com/en-MY/windows7/Change-settings-for-a-Bluetooth-enabled-device

Add a device or computer to a network

http://windows.microsoft.com/en-MY/windows7/Add-a-device-or-computer-to-a-network

Let us know if it helps.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I also have Win 7 Ulimate and like Faraz never get any devices showing.  However I know that this is an operating system issue as I have also installed Win 7 Ultimate to an external eSATA drive and when I boot from this everything works using standard drivers that come with the OS, but not so when I use the internal SSD hard drive.

Device Manager shows that the Bluetooth radios are working properly but under other devices I have 3 Bluetooth Peripheral devices that showproblems.  Any attempts to update drivers do not do anything that is helpful. When I look for driver details  from the driver tab it reports that none are required or have been loaded.  When I go down the Update Driver route from the general tab Windows cannot find any from the web.  When I look for drivers from the driver location I have for all drivers it fails.

Just looking for my phone or my mouse fails and no other devices are ever found even when discovery is enabled.  However all of this works from my externally bootable OS.

I have tried to use recovery to no avail and have tried to repair the OS as well.

I think some assemblies must be missing or something in registry is wrong but have no idea where to look for and have done all the obvious things that I can think of. 

 

I am thinking of installing Windows 8 but would prefer to have this resolved before I do that.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.