Win32 error code returned by the print processor: 2147500037. Unspecified error__

I have been trying to setup a wired network printer at home and have run into some problems.  I have an HP photosmart c5180 all in one printer.  It woks perfectly when connected by USB to either of my windows 7 32 bit laptops, but I thought it would be nice to connect the printer to the router and print wirelessly.

I have installed the drivers and patch from HP (several times now) and still get the same problem.  When I send a print job it will show up in the print queue for a couple of seconds before disappearing and nothing prints.  When I changed a setting so that the finished print jobs stayed in the queue I noticed that the print jobs sent and said that it had printed. 

One interesting thing is the software that came from HP includes an hp solution center which gets correct info from the printer about the ink levels and says it is connected and functioning.  From the HP solution center I can also get the printer to scan, copy and even print a test page (when I try to print a test page from printer properties outside of hp solution center it does not work).  I have tried to print from different programs like word, excel, notepad etc. but always get the same result.

After spending way too much time trying to solve this I learned how to find the printservice on the event viewer and have found the error message associated with the problem.  here is the full message:

The document Microsoft Word - portugal games, owned by Shays EEE, failed to print on printer HP Photosmart C5100 series. Try to print the document again, or restart the print spooler.

Data type: NT EMF 1.008. Size of the spool file in bytes: 196608. Number of bytes printed: 0. Total number of pages in the document: 2. Number of pages printed: 0. Client computer: \\SHAYSEEE-PC. Win32 error code returned by the print processor: 2147500037. Unspecified error

basically the same error every time.

I have tried to uninstall and reinstalled all hp software and drivers

I have turned the print spooler off and on

I have tried multiple settings in the printer properties menu

I have begun to pull my hair out!

Any help would be appreciated, but if it cant be straightened out then I guess I can just take the extra effort to plug in the USB

Thanks

 

Question Info


Last updated December 3, 2018 Views 29,619 Applies to:
Answer

Hi,

Refer this thread link and look for the solution given by “Cari MVP”. Check if it works for you.

http://social.answers.microsoft.com/Forums/en/w7hardware/thread/b628c65c-bc62-4c50-8f43-720a5c23bf11

You may also refer this thread link for a different solution:

http://social.technet.microsoft.com/Forums/en/w7itpronetworking/thread/ef0fcaa8-84bf-4b71-b664-19d10bf0f728  

Regards,
Afzal-Microsoft Support.
Visit our Microsoft Answers Feedback Forum and let us know what you think.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.