Win-7 write protection on an external USB HD, how do I write enable?

I am new to Windows 7 and after connecting two external USB hard drives when I try to change the name of a file or add files to them I get a message stating they are write protected, where does one go to turn off write protection on an external USB drive? Thesedrives contain my archives of CDs I have ripped to .mp3 for use with my mp3 players.  I origninally created these archives on a Win XP-Pro system (one drive is FAT-32, the other NTFS).  TIA


Question Info

Last updated February 26, 2020 Views 3,910 Applies to:

Hello Chris,

I would suggest you to follow these steps and check if it helps:

a.   Right-click the file and selectProperties.

b.   Click on theSecurity tab.

c.   ClickAdvanced in the lower right.

d.   In the Advanced Security Settings window that pops up, click on theOwner tab.

e.   ClickEdit.

f.    ClickOther users or groups.

g.   ClickAdvanced in the lower left corner.

h.   ClickFind Now.

i.     Scroll through the results and double-click on your current user account.

j.    ClickOK to all of the remaining windows except the first Properties window.

k.   Select your user account from the list up top and clickEdit.

l.     Select your user account from the list up top again and then in the pane below, checkFull control under Allow, or as much control as you need.

m. You’ll get a security warning, clickYes.


For more information refer these links:


Also check if the external hard drive is write protected, right click on the drive, go to properties and remove write protected option and check if it helps.


Savan – Microsoft Support.


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.