Virtual Disk service will not start

Hi,

I have recently bought a new hard drive, and am trying to format it using the disk management utility. I get a "Connecting to Virtual Disk Service" message that stays there indefinatly. I retraced the problem to the Virtual Disk service in the services browser, and I can't get it to start.

If I manualy try it, I get a "Windows could not start the Virtual Disk service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion." message, and the services browser lists Virtual Disk as Starting. The service is also there in the task manager's service tab under vds.exe, I cannot stop it (Access is denied).

I have made sure that all the required services (Plug and play, RPC, DCMO, RPC Endpoint) are already started.

Setting Virtual Disk to automatic will do nothing after a reboot, just list it as "starting". I have tried disconecting all my drives (DVD, three other HDDs including the new one) other than the OS drive, same problem. Tried safe mode, same problem.

I just can't get this damn device to start to format my drive :/

My computer is :

Intel E6400
Intel DG965WH
5.5gb of mixed ram (Mostly Kingston)
1x 160gb Seagate HHD (OS)
1x 160gb Seagate
1x 500gb Seagate
1x 1tb Seagate (new drive)
Windows 7 Home Premium 32bits up to date (Yeah I know, need 64 for my ram...)

Thanks!
 

Question Info


Last updated September 20, 2018 Views 53,111 Applies to:
Answer

Hi,

I would suggest you to run System File Checker, here are the steps:

 To perform the system file checker use these step:

 1.Click Start, click All Programs, click Accessories, right-click Command Prompt, and select Run as Administrator.
2.Click Continue or supply Administrator credentials if prompted.
3.In the Command Prompt window type the following, and press Enter:
sfc /scannow
4.You should see the following on-screen messages:

Beginning the system scan. This process will take some time.
Beginning verification phase of system scan.
Verification % complete.

5.Once the scan has completed you will receive an onscreen message resembling one of the following:
…found no integrity violations
…found corruption but repaired it
…found corruption that it could not repair

 Please reply with the completion message that you received.

 You can also try with these steps:

1. Click start type services and press enter.
2. In the Services tool, click the service that you want to start, and then click Properties.
3. Right-click the Log On tab, and then click to select the Allow service to interact with desktop check box.
4. Click OK to exit the Properties dialog box.

Please respond back for the status on the issue and let us know if you have any issues.

Azam – Microsoft Support.

 

 

75 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.