USB Suspend:USB Device not Entering Suspend -- preventing Windows 7 Pro x64 from suspending

Recently, my Windows 7 partition refused to go to sleep or hibernate. I poked around, and found out that I needed to run "powercfg -energy", which I did as I tried a sleep.

It turned out that the USB hubs were apparently keeping Windows from sleeping (although this has not been an issue in the past). So, in response, I removed my USB mouse connector.

The number of errors dropped down from 5 to 3. Now, only the following remain:

Errors
USB Suspend:USB Device not Entering Suspend
The USB device did not enter the Suspend state. Processor power management may be prevented if a USB device does not enter the Suspend state when not in use.
Device Name USB Mass Storage Device
Host Controller ID PCI\VEN_10DE&DEV_077C
Host Controller Location PCI bus 0, device 2, function 1
Device ID USB\VID_0BDA&PID_0158
Port Path 1
USB Suspend:USB Device not Entering Suspend
The USB device did not enter the Suspend state. Processor power management may be prevented if a USB device does not enter the Suspend state when not in use.
Device Name USB Root Hub
Host Controller ID PCI\VEN_10DE&DEV_077C
Host Controller Location PCI bus 0, device 2, function 1
Device ID USB\VID_10DE&PID_077C
Port Path
CPU Utilization:Processor utilization is high
The average processor utilization during the trace was high. The system will consume less power when the average processor utilization is very low. Review processor utilization for individual processes to determine which applications and services contribute the most to total processor utilization.
Average Utilization (%) 7.16

My guess is that the "USB Mass storage device" is my card-reader, built into the laptop. I found it in the device manager, and then disabled it and uninstalled it, to no avail.

So what now? I never had this issue before--why did it appear now?

 

Question Info


Last updated April 2, 2020 Views 12,988 Applies to:
Answer
Answer

Well alrighty then. I got it fixed, thanks to the comment by AndyWalser here.

I had recently installed SUSE 11.2 x64. I figured this could in no way be related since the issue was apparently USB. Turns out that, for some reason, with GRUB as the bootloader, it un-marks the Win7 partition as "Active." The moment I re-marked it as active, sleep and hibernate worked without a hitch.

If anyone else is having similar issues, just go to Computer Management>Disk Management and mark the Win7 partition as Active.

The real question, though, is what that has to do with USB not suspending at all.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.