Question

Q: Unable to install printer driver - access denied error

I have two brand new Inspiron 1545 laptops running Windows 7 64-bit edition that are exhibiting that same issue.  I am trying to get an Epson Color Stylus 760 printer working with them via a USB connection.

When I initially attach the the device is recognised correctly but the Epson driver doesn't correctly install.  If I run Windows Update, the Epson driver is listed as an optional update.  If I select it and run the update, it fails with error 80070005.

If I go to the device manager, the printer is listed as a USB printer that isn't running correctly as there's no driver.  If I choose to 'update driver' from the device manager, it successfully downloads the driver (same driver as listed in Windows Update) and when trying to install the driver it comes back with an error of 'Access Denied'.

As previously mentioned this occurs with both laptops.  In both cases I was logged in as an administrator account but not 'the' administrator account.  I have enabled the administator account and tried installing through this but it made no difference.  I also have tried removing and reinstalling the device without success.

The Windows 7 compatibility site stated that the printer is compatible with Windows 7 64-bit edition.

Answer

A:

Hi Shawn,

I believe their is a Windows 7 64-bit driver as per this website:


The Epson Stylus Color 760 has a 'built in Windows 7 driver'.

Nonetheless, I'll give your suggestion a try if Alan's doesn't work.

Regards,
Dan

Did this solve your problem?

Sorry this didn't help.

17 people were helped by this reply



 
Question Info

Views: 52,482 Last updated: May 16, 2018 Applies to: