the MTP USB Device driver doesn't install. I cannot connect external devices such as the Samsung Galaxy. I tried multiple uninstall and re-install, no solution

i tried many of the ways suggested in many forums, nothing worked. actually when i forst connected te Galaxy it worked for a few days, then it stopped. My company ha installed on my PC System Center 2012 Endpoint Protection; however it was there even when i was able to connect.  i tird also the ipad and i get the same error.

the solution offered to my previous request on the same issue by Rob Thomas596 strictly refers to Apple products and i can't use it for the Galaxy


Run command prompt as administrator and run the following command:

net localgroup Administrators local service /add

That is what fixed my problem after searching everywhere

Michael J Warren

868 people found this reply helpful


Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.


Question Info

Last updated June 12, 2021 Views 361,170 Applies to: