Q: the MTP USB Device driver doesn't install. I cannot connect external devices such as the Samsung Galaxy. I tried multiple uninstall and re-install, no solution This thread is locked from future replies

i tried many of the ways suggested in many forums, nothing worked. actually when i forst connected te Galaxy it worked for a few days, then it stopped. My company ha installed on my PC System Center 2012 Endpoint Protection; however it was there even when i was able to connect.  i tird also the ipad and i get the same error.

the solution offered to my previous request on the same issue by Rob Thomas596 strictly refers to Apple products and i can't use it for the Galaxy



Run command prompt as administrator and run the following command:

net localgroup Administrators local service /add

That is what fixed my problem after searching everywhere

Michael J Warren

Did this solve your problem?

Sorry this didn't help.

813 people were helped by this reply

Question Info

Views: 351,377 Last updated: March 18, 2018 Applies to: