Ports - Com and Lpt not in device manager

I do not have the "Ports" option showing up in device manager in Windows 7.  I have an internal modem, and I am trying to tether my blackberry, and there are no Ports - Com or Lpt.  It's just not there.  Any ideas?
 

Question Info


Last updated April 18, 2019 Views 91,218 Applies to:
Answer

Hi emstaples,

 

1.      Check if the device is hidden device.

i.                    Click show hidden devices under View

ii.                  expand all the nods under device manager

iii.                There would be many grayed out entries in device manager uninstall all the grayed out entries under all the nods and then restart the computer and plug the external device to the computer and check if it works.

 

2.      Check in the BIOS (integrated peripherals) if the com ports are enabled and set to 'auto'

 

BIOS DISCLAIMER: Modifying BIOS/complementary metal oxide semiconductor (CMOS) settings incorrectly can cause serious problems that may prevent your computer from booting properly. Microsoft cannot guarantee that any problems resulting from the configuring of BIOS/CMOS settings can be solved. Modifications of the settings are at your own risk.

 

3.      If the above steps does not resolve then you might need to install the driver manually.

 

     Link: Installing new hardware: recommended links: http://windows.microsoft.com/en-us/windows7/Installing-new-hardware-recommended-links

 

     Other link you may refer to: http://windows.microsoft.com/en-US/windows7/Install-or-remove-a-modem

 

Thanks and Regards:

Samhrutha G S - Microsoft Support.

Visit our Microsoft Answers Feedback Forum and let us know what you think.

 

76 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.