Q: Plug and Play usb devices won't work on my Win 7 This thread is locked from future replies



I have a Lenovo 3000 Y410 Windows 7 64bit. I am having a problem with my laptop because it does not install usb devices, it detects the devices but cannot install it. It appears on the device manager but with exclamation mark. I've tried to update the drive but always sayes "driver not found". Even the troubleshooting didn't do any help. These are plug and play devices (flash disk, external hd, usb hub, usb keyboard, wireless mouse) that should automatically be recognized by Win7. These device works perfectly fine with other machines. Each time there is a driver issue everyone can only suggest is that go to the manufacturer's website and download the drivers. However, these are plug and play devices, if that is the solution then I would be downloading each driver for every flash disk that I connect to my machine. I think that's not right, I doubt that the problem relies on the device rather there is something wrong with the OS or the machine.


Any thoughts about this?

Hi Stephen FranelVillavert,

Let’s first check if the external hard disk has any error message/code listed under it in Device Manager.

·         Right-clicks the device (external hard disk) in Device Manager and select Properties.

·         Under General tab, check for the status of the device under Device status.

Does it show any error message/code associated with the device?

 In the mean time you may follow the methods listed below and check if the issue gets fixed.

Uninstall the USB controller

Use Device Manager to disable and re-enable all the USB controllers. This lets the controllers recover the USB port from its unresponsive condition. The USB controllers represent the USB ports in Device Manager.

To disable and re-enable the USB controllers, follow these steps:

1.    Click Start, type device manager in the Start search box and hit Enter.

2.    Expand Universal Serial Bus controllers.

Note: You might have to scroll down the list to find this item.

3.    Right-click the first USB controller under Universal Serial Bus controllers, and then click Uninstall to remove it.

4.    Repeat the above step for each USB controller that is listed under Universal Serial Bus controllers.

5.    Restart the computer. After the computer starts, Windows will automatically scan for hardware changes and reinstall all the USB controllers that you uninstalled.

6.    Check the USB device to see whether it is working.

Hope the information helps.

Did this solve your problem?

Sorry this didn't help.

9 people were helped by this reply

Hi Imran,


I've done exactly what you've said, all USB controllers have been reinstalled however, including my wireless RF mouse (which is working fine before) no longer works. When I plug it in, Windows starts searching for the driver then ended up failing to install the driver. On the device manager the said devices has an exlamation symbol.


Just additional information, I've tried to uninstall all items under the "Other device" on the device manager then reboot. The keyboard and mouse is working until login however when Windows starts searching for the driver and fails to install the driver, then those devices stops working.

Did this solve your problem?

Sorry this didn't help.

I've just noticed, there is no Human Interface Device node on the Device Manager. Is it possible that it has a relation with the problem?

Did this solve your problem?

Sorry this didn't help.

I know this is an old post, but it shows up at the top of google searches for this problem and wanted to post my solution.

I had this problem, and it extended to ALL devices not just USB. The problem turned out to be that I had installed a half-arsed program that incorrectly modified the value of HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DevicePath, which normally defaults  to "%SystemRoot%\inf".

They tried to add their own directory to the path, but the fools rewrote the key as REG_SZ instead of REG_EXPAND_SZ, which is necessary whenever the string contains an environmental variable.

Every time installation of a new device was attempted, the following error would appear in C:\Windows\inf\

     dvi:      Enumerating INFs from path list '%SystemRoot%\inf'
     inf:      The path %SystemRoot%\inf\*.* is missing!

Consequently, NO device would plug an play, including any system devices one might uninstall to try and force a fresh install. Not knowing about the above bug, when I updated several drivers, my system blue screened because several system devices "disappeared", including the system drive.

Once I used the system recovery tool to install a restore point prior to the attempted driver upgrades and then figured out the problem, I deleted the old DevicePath key an made a new one with the correct data type and that fixed everything. (While I was at it, I set the DevicePath back to the default value and uninstalled the offending program.)

Did this solve your problem?

Sorry this didn't help.

Question Info

Views: 6,821 Last updated: March 13, 2018 Applies to: